package/gupnp: needs host-vala for introspection
authorAdam Duskett <Aduskett@gmail.com>
Fri, 27 Mar 2020 18:29:59 +0000 (11:29 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 31 Mar 2020 20:24:19 +0000 (22:24 +0200)
Introspection support in gupnp is handled by way of vala tools and
vala bindings.

Even though host-vala is already a transitive dependency via gssdp,
add it to gupnp for correctness sake; also explicitly enable the
generation of the vala API, since it is required for introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gupnp/gupnp.mk

index 66a6e76574b8e97db9ad19f92a9a660c6c64ad0f..dfe25e16c5ffd1a97eebfe7da52e0b1fded34bad 100644 (file)
@@ -15,10 +15,10 @@ GUPNP_DEPENDENCIES = host-pkgconf libglib2 libxml2 gssdp util-linux
 GUPNP_CONF_OPTS = -Dexamples=false
 
 ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
-GUPNP_CONF_OPTS += -Dintrospection=true
-GUPNP_DEPENDENCIES += gobject-introspection
+GUPNP_CONF_OPTS += -Dintrospection=true -Dvapi=true
+GUPNP_DEPENDENCIES += host-vala gobject-introspection
 else
-GUPNP_CONF_OPTS += -Dintrospection=false
+GUPNP_CONF_OPTS += -Dintrospection=false -Dvapi=false
 endif
 
 $(eval $(meson-package))