python-pyjwt: new package
authorGrzegorz Blach <grzegorz@blach.pl>
Thu, 30 Aug 2018 10:18:48 +0000 (12:18 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 26 Mar 2019 23:13:04 +0000 (00:13 +0100)
PyJWT is a Python library which allows you to encode and decode
JSON Web Tokens (JWT). JWT is an open, industry-standard (RFC 7519)
for representing claims securely between two parties.

https://github.com/jpadilla/pyjwt

Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
[Arnout: bump to 1.7.1]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
DEVELOPERS
package/Config.in
package/python-pyjwt/Config.in [new file with mode: 0644]
package/python-pyjwt/python-pyjwt.hash [new file with mode: 0644]
package/python-pyjwt/python-pyjwt.mk [new file with mode: 0644]

index eaf8250591073526997d30af6d52949362ec9a17..3dfdf894d77f429c9cee5d42ab524cd4f2dacc20 100644 (file)
@@ -944,6 +944,7 @@ F:  package/python-aioblescan/
 F:     package/python-falcon/
 F:     package/python-mimeparse/
 F:     package/python-pigpio/
+F:     package/python-pyjwt/
 F:     package/python-wtforms/
 
 N:     Guillaume Gardet <guillaume.gardet@oliseo.fr>
index a3ac229c77c078a4af1f1cf31d816f78be0540c2..09a2b806141937eebdbe25180bb64a1c1e8f9dda 100644 (file)
@@ -982,6 +982,7 @@ menu "External python modules"
        source "package/python-pyhamcrest/Config.in"
        source "package/python-pyicu/Config.in"
        source "package/python-pyinotify/Config.in"
+       source "package/python-pyjwt/Config.in"
        source "package/python-pylibftdi/Config.in"
        source "package/python-pylru/Config.in"
        source "package/python-pymodbus/Config.in"
diff --git a/package/python-pyjwt/Config.in b/package/python-pyjwt/Config.in
new file mode 100644 (file)
index 0000000..510875c
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_PYJWT
+       bool "python-pyjwt"
+       help
+         JSON Web Token implementation in Python.
+
+         http://github.com/jpadilla/pyjwt
diff --git a/package/python-pyjwt/python-pyjwt.hash b/package/python-pyjwt/python-pyjwt.hash
new file mode 100644 (file)
index 0000000..62ec355
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/PyJWT/json
+md5    a4712f980c008696e13e09504120b2a0  PyJWT-1.7.1.tar.gz
+sha256 8d59a976fb773f3e6a39c85636357c4f0e242707394cadadd9814f5cbaa20e96  PyJWT-1.7.1.tar.gz
+# Locally computed sha256 checksums
+sha256 ec82af815b5f9da8685afb300cc5beb7949e1c22b79b6c1c054796cefdf6cac6  LICENSE
diff --git a/package/python-pyjwt/python-pyjwt.mk b/package/python-pyjwt/python-pyjwt.mk
new file mode 100644 (file)
index 0000000..dfc66e5
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-pyjwt
+#
+################################################################################
+
+PYTHON_PYJWT_VERSION = 1.7.1
+PYTHON_PYJWT_SOURCE = PyJWT-$(PYTHON_PYJWT_VERSION).tar.gz
+PYTHON_PYJWT_SITE = https://files.pythonhosted.org/packages/2f/38/ff37a24c0243c5f45f5798bd120c0f873eeed073994133c084e1cf13b95c
+PYTHON_PYJWT_SETUP_TYPE = setuptools
+PYTHON_PYJWT_LICENSE = MIT
+PYTHON_PYJWT_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))