libuv: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 18 Jul 2014 20:24:18 +0000 (17:24 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Jul 2014 09:40:15 +0000 (11:40 +0200)
[Thomas: add comment suggested by Yann E. Morin.]

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libuv/Config.in [new file with mode: 0644]
package/libuv/libuv.mk [new file with mode: 0644]

index db2d114f5f8472be470b62cce0ea379481441cce..f9722f6b6cabe786ff213e73ee81fb644834a816 100644 (file)
@@ -849,6 +849,7 @@ menu "Other"
        source "package/libuci/Config.in"
        source "package/libunwind/Config.in"
        source "package/liburcu/Config.in"
+       source "package/libuv/Config.in"
        source "package/linux-pam/Config.in"
        source "package/lttng-libust/Config.in"
        source "package/mpc/Config.in"
diff --git a/package/libuv/Config.in b/package/libuv/Config.in
new file mode 100644 (file)
index 0000000..6083837
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBUV
+       bool "libuv"
+       depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       help
+         libuv is a multi-platform support library with a focus
+         on asynchronous I/O.
+
+         https://github.com/joyent/libuv
+
+comment "libuv needs a toolchain w/ IPv6, threads"
+       depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
diff --git a/package/libuv/libuv.mk b/package/libuv/libuv.mk
new file mode 100644 (file)
index 0000000..986acee
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# libuv
+#
+################################################################################
+
+LIBUV_VERSION = v0.11.26
+LIBUV_SITE = $(call github,joyent,libuv,$(LIBUV_VERSION))
+LIBUV_DEPENDENCIES = host-pkgconf
+LIBUV_INSTALL_STAGING = YES
+LIBUV_AUTORECONF = YES
+LIBUV_LICENSE = BSD-2c, BSD-3c, ISC, MIT
+LIBUV_LICENSE_FILES = LICENSE
+
+# Upstream needs tests to be run sequentially. This is the default in
+# automake 1.11 and before, but not starting in 1.12. To maintain
+# sequentiality in 1.12 and later, the automake option 'serial-tests'
+# must be used, Unfortunately, it is not recognised by 1.11 and
+# before. So upstream only adds it conditionally. We use automake
+# 1.14, so we need it.
+define LIBUV_FIXUP_AUTOGEN
+       echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+               >$(@D)/m4/libuv-extra-automake-flags.m4
+endef
+LIBUV_POST_PATCH_HOOKS += LIBUV_FIXUP_AUTOGEN
+
+$(eval $(autotools-package))