snmppp: add option to disable SNMPv3 support
authorLuca Ceresoli <luca@lucaceresoli.net>
Sun, 6 Apr 2014 22:20:05 +0000 (00:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 7 Apr 2014 23:19:50 +0000 (01:19 +0200)
Disabling SNMPv3 support also removes the dependency on OpenSSL, which is
pretty large (over 2 MB of uncompressed filesystem size on an ARM926 platform).

BR2_PACKAGE_SNMPPP_SNMPV3 defaults to yes for backward compatibility with
previous Buildroot releases, where SNMPv3 was always enabled.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/snmppp/Config.in
package/snmppp/snmppp.mk

index 1d5113fbb0f1b47ea687880e019d2da41ff14632..8b69fabe43ccffd5814a9cbf1c5b3dac2ba0bc48 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_SNMPPP
        bool "snmp++"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       select BR2_PACKAGE_OPENSSL
        help
          SNMP++v3.x is a C++ API which supports SNMP v1, v2c, and v3.
 
@@ -17,6 +16,13 @@ config BR2_PACKAGE_SNMPPP_LOGGING
          According to the SNMP++ documentation, disabling logging "increases
          performance drastically and minimizes memory consumption".
 
+config BR2_PACKAGE_SNMPPP_SNMPV3
+       bool "enable SNMPv3"
+       default y
+       select BR2_PACKAGE_OPENSSL
+       help
+         Enable optional support for SNMP++. This selects OpenSSL.
+
 endif
 
 comment "snmp++ needs a toolchain w/ threads, C++"
index 3f3018d2ad5890c83db6e0dcd0bbf22488fabb39..57c49629389ae8c6bb95a453498433e8f725a6d7 100644 (file)
@@ -7,7 +7,7 @@
 SNMPPP_VERSION = 3.3.4
 SNMPPP_SOURCE = snmp++-$(SNMPPP_VERSION).tar.gz
 SNMPPP_SITE = http://www.agentpp.com
-SNMPPP_DEPENDENCIES = openssl host-pkgconf
+SNMPPP_DEPENDENCIES = host-pkgconf
 SNMPPP_INSTALL_STAGING = YES
 # no configure script in tarball
 SNMPPP_AUTORECONF = YES
@@ -15,4 +15,11 @@ SNMPPP_CONF_OPT = $(if $(BR2_PACKAGE_SNMPPP_LOGGING),--enable-logging,--disable-
 SNMPPP_LICENSE = SNMP++
 SNMPPP_LICENSE_FILES = src/v3.cpp
 
+ifeq ($(BR2_PACKAGE_SNMPPP_SNMPV3),y)
+       SNMPPP_CONF_OPT += --enable-snmpv3
+       SNMPPP_DEPENDENCIES += openssl
+else
+       SNMPPP_CONF_OPT += --disable-snmpv3
+endif
+
 $(eval $(autotools-package))