core: simplify the condition to set the strip command
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 1 Jul 2017 12:51:20 +0000 (14:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Jul 2017 13:01:01 +0000 (15:01 +0200)
Since BR2_STRIP_strip and BR2_STRIP_noine are mutually exclusive (being
part of a choice), we can simplify the logic.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in

index c1dc7143310b76b2df19cfc9f2a84f8dd1d39f49..8087bde999c09c0148eef2ef5fc066243ba4ad04 100644 (file)
@@ -205,8 +205,7 @@ ifeq ($(BR2_STRIP_strip),y)
 STRIP_STRIP_DEBUG := --strip-debug
 TARGET_STRIP = $(TARGET_CROSS)strip
 STRIPCMD = $(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
-endif
-ifeq ($(BR2_STRIP_none),y)
+else
 TARGET_STRIP = /bin/true
 STRIPCMD = $(TARGET_STRIP)
 endif