ejabberd: Call check-erlang-lib script directly from its location
authorJohan Oudinet <johan.oudinet@gmail.com>
Tue, 13 Feb 2018 13:27:11 +0000 (14:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 20 May 2018 19:51:58 +0000 (21:51 +0200)
Avoid installing check-erlang-lib in the directory where the tarball is
extracted. Instead, use an absolute path to its actual location, i.e.:
$(TOPDIR)/$(EJABBERD_PKGDIR)/check-erlang-lib

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ejabberd/ejabberd.mk

index 0f7af9b83ea344f70a306300aa2f0973a393de8f..acd52e5b38d592fd418f8f45ffc6603db5a8025a 100644 (file)
@@ -23,24 +23,15 @@ ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 EJABBERD_DEPENDENCIES += linux-pam
 endif
 
-# Install check-erlang-lib script to the directory in which the
-# package has been uncompressed, so it is available during the
-# configure step.
-define EJABBERD_INSTALL_CHECK_ERLANG_LIB
-       $(INSTALL) -m 0755 $(EJABBERD_PKGDIR)/check-erlang-lib \
-               $(@D)/check-erlang-lib
-endef
-
-EJABBERD_POST_EXTRACT_HOOKS += EJABBERD_INSTALL_CHECK_ERLANG_LIB
-
 EJABBERD_ERLANG_LIBS = sasl public_key mnesia inets compiler
 
 # Guess answers for these tests, configure will bail out otherwise
 # saying error: cannot run test program while cross compiling.
+EJABBERD_CHECK_LIB = $(TOPDIR)/$(EJABBERD_PKGDIR)/check-erlang-lib
 EJABBERD_CONF_ENV = \
        ac_cv_erlang_root_dir="$(HOST_DIR)/lib/erlang" \
        $(foreach lib,$(EJABBERD_ERLANG_LIBS), \
-               ac_cv_erlang_lib_dir_$(lib)="`./check-erlang-lib $(lib)`")
+               ac_cv_erlang_lib_dir_$(lib)="`$(EJABBERD_CHECK_LIB) $(lib)`")
 
 EJABBERD_CONF_OPTS = \
        --enable-system-deps \