fs/common.mk: do not store original names and timestamps when creating gzipped rootfs
authorAtharva Lele <itsatharva@gmail.com>
Tue, 16 Jul 2019 17:42:13 +0000 (23:12 +0530)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 17 Jul 2019 06:45:11 +0000 (08:45 +0200)
Using the GZIP environment variable to pass gzip options is
deprecated, and therefore we are going to remove the "GZIP = -n"
definition from the main Buildroot Makefile. In preparation for this,
we explicitly add the -n argument to the gzip call in fs/common.mk to
ensure reproducibility.

Signed-off-by: Atharva Lele <itsatharva@gmail.com>
Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
fs/common.mk

index fceb38c5b915c6279b4e082119eeb6029f071fca..ca46a331d6a369e85926ff2adf77633b1d57f5d3 100644 (file)
@@ -115,7 +115,7 @@ ROOTFS_$(2)_FINAL_RECURSIVE_DEPENDENCIES = $$(sort \
 
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)_GZIP),y)
 ROOTFS_$(2)_COMPRESS_EXT = .gz
-ROOTFS_$(2)_COMPRESS_CMD = gzip -9 -c
+ROOTFS_$(2)_COMPRESS_CMD = gzip -9 -c -n
 endif
 ifeq ($$(BR2_TARGET_ROOTFS_$(2)_BZIP2),y)
 ROOTFS_$(2)_COMPRESS_EXT = .bz2