package/qemu: disable SDL2 for the host variant
authorRomain Naour <romain.naour@gmail.com>
Mon, 6 Apr 2020 14:21:59 +0000 (16:21 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 18:18:13 +0000 (20:18 +0200)
There is no host variant for SDL2 library in Buildroot.
So the qemu build system will try to detect automatically the
external SDL2 libraries installed on the host.

$ ldd output/host/bin/qemu-system-aarch64
[...]
libSDL2-2.0.so.0 => /lib64/libSDL2-2.0.so.0

Disable explicitely sdl2 options (named sdl) to improve the
build reproducibility.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qemu/qemu.mk

index 06841a56d03c0eae8fded033a86e96570bf04b49..712491a208fd4f521474f3c867283194daebeba6 100644 (file)
@@ -305,6 +305,7 @@ define HOST_QEMU_CONFIGURE_CMDS
                --python=$(HOST_DIR)/bin/python3 \
                --disable-bzip2 \
                --disable-libssh \
+               --disable-sdl \
                --disable-vnc-jpeg \
                --disable-vnc-png \
                --disable-vnc-sasl \