libv4l: fix utilities build with older glibc versions
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Nov 2014 10:21:21 +0000 (11:21 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Nov 2014 10:25:18 +0000 (11:25 +0100)
Fixes:
http://autobuild.buildroot.net/results/9af/9af37fbf344b63b60e59ccac21e010cdf0ea219e/
http://autobuild.buildroot.net/results/bbd/bbd34d5378354e9db7822eaae8d3c4a75a67ac23/
http://autobuild.buildroot.net/results/ebb/ebbaa70e1a277162ba53c7bde8335ee998486703/
http://autobuild.buildroot.net/results/2c1/2c11f4dbb7cfadcfc6fbc267679b2b4eab867221/

And many more.

The utilities use clock_gettime(), which was provided in librt in glibc <
2.17, so ensure we link against -lrt.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libv4l/libv4l.mk

index 732fad5008ae8f9964179beec7cb596142f1ccee..63dd5d2f04effc1b7faa1b9117418559c769b954 100644 (file)
@@ -17,7 +17,7 @@ LIBV4L_LICENSE_FILES = COPYING COPYING.libv4l lib/libv4l1/libv4l1-kernelcode-lic
 
 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
 LIBV4L_DEPENDENCIES += argp-standalone
-LIBV4L_CONF_ENV += LIBS="-largp"
+LIBV4L_LIBS += -largp
 endif
 
 LIBV4L_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
@@ -38,8 +38,12 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBV4L_UTILS),y)
 LIBV4L_CONF_OPTS += --enable-v4l-utils
+# clock_gettime is used, which is provided by librt for glibc < 2.17
+LIBV4L_LIBS += -lrt
 else
 LIBV4L_CONF_OPTS += --disable-v4l-utils
 endif
 
+LIBV4L_CONF_ENV += LIBS="$(LIBV4L_LIBS)"
+
 $(eval $(autotools-package))