package/nvidia-driver: use += where appropriate
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Oct 2018 22:14:35 +0000 (00:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 3 Dec 2018 22:07:40 +0000 (23:07 +0100)
Within the BR2_PACKAGE_NVIDIA_DRIVER_XORG condition, some "="
assignements are used for various variables, which are also appended
in other conditions below in nvidia-driver.mk.

It works fine because those assignements appear earlier in the .mk,
but it is a bit error-prone, so let's use += when adding values to
those variables.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nvidia-driver/nvidia-driver.mk

index a595aed4f73c92f6da60bd534f6ca6571c7f2fe4..0d051fcaa4488034635aeea82f635886b16fd80f 100644 (file)
@@ -20,8 +20,8 @@ ifeq ($(BR2_PACKAGE_NVIDIA_DRIVER_XORG),y)
 # are build dependencies of packages that depend on nvidia-driver, so
 # they should be built prior to those packages, and the only simple
 # way to do so is to make nvidia-driver depend on them.
-NVIDIA_DRIVER_DEPENDENCIES = mesa3d-headers xlib_libX11 xlib_libXext
-NVIDIA_DRIVER_PROVIDES = libgl libegl libgles
+NVIDIA_DRIVER_DEPENDENCIES += mesa3d-headers xlib_libX11 xlib_libXext
+NVIDIA_DRIVER_PROVIDES += libgl libegl libgles
 
 # libGL.so.$(NVIDIA_DRIVER_VERSION) is the legacy libGL.so library; it
 # has been replaced with libGL.so.1.0.0. Installing both is technically
@@ -65,7 +65,7 @@ NVIDIA_DRIVER_LIBS_MISC = \
        libvdpau_nvidia.so.$(NVIDIA_DRIVER_VERSION) \
        libnvidia-ml.so.$(NVIDIA_DRIVER_VERSION)
 
-NVIDIA_DRIVER_LIBS = \
+NVIDIA_DRIVER_LIBS += \
        $(NVIDIA_DRIVER_LIBS_GL) \
        $(NVIDIA_DRIVER_LIBS_EGL) \
        $(NVIDIA_DRIVER_LIBS_GLES) \