Makefile: revert BUILD_DIR export
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 24 Oct 2013 18:11:25 +0000 (15:11 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 25 Oct 2013 06:10:23 +0000 (08:10 +0200)
Revert commit feb0877015cc0c644129e69276b3000c83742750
U-Boot uses $(BUILD_DIR) and causes issues, other packages might as
well. Fixes:
http://autobuild.buildroot.net/results/1f6/1f65289d5c284caa82a4e9137613f792797ee08a/
http://autobuild.buildroot.net/results/6a5/6a5f77483e908dc96d08824cf9113402431bace7/

It should probably be named somewhat more uniquely.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile
docs/manual/customize-rootfs.txt

index 9528703b5617d462a1af5e9d4a97d63e164ea6a7..f266e2dd77bf89bdfa91801558606e91cd8455e7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -291,7 +291,6 @@ export STAGING_DIR
 export HOST_DIR
 export BINARIES_DIR
 export BASE_DIR
-export BUILD_DIR
 
 ################################################################################
 #
index 158389c8a7e70d44928cbb13fe86cbfb2776eed1..49a6b4b44285143c1915060973f4fd3c727a22f0 100644 (file)
@@ -41,7 +41,6 @@ there are a few ways to customize the resulting target filesystem.
     - +BUILDROOT_CONFIG+: the path to the Buildroot .config file
     - +HOST_DIR+, +STAGING_DIR+, +TARGET_DIR+: see
       xref:generic-package-reference[]
-    - +BUILD_DIR+: the directory where packages are extracted and built
     - +BINARIES_DIR+: the place where all binary files (aka images) are
       stored
     - +BASE_DIR+: the base output directory
@@ -80,7 +79,7 @@ in one of these _post-image scripts_ will require special handling
 Just like for the _post-build scripts_ mentioned above, you also have
 access to the following environment variables from your _post-image
 scripts_: +BUILDROOT_CONFIG+, +HOST_DIR+, +STAGING_DIR+, +TARGET_DIR+,
-+BUILD_DIR+, +BINARIES_DIR+ and +BASE_DIR+.
++BINARIES_DIR+ and +BASE_DIR+.
 
 Additionally, each of the +BR2_ROOTFS_POST_BUILD_SCRIPT+ and
 +BR2_ROOTFS_POST_IMAGE_SCRIPT+ scripts will be passed the arguments