python-nfc: new package
authorSimon Dawson <spdawson@gmail.com>
Fri, 20 Jul 2012 08:58:12 +0000 (09:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 19:08:25 +0000 (21:08 +0200)
[thomas.petazzoni@free-electrons.com:
   add patch that creates a standard setup.py file. This allows the
   .pyc files to be generated at build time, and installed into the
   target. This is important because by default, Buildroot removes all
   .py files from the target, to keep only the .pyc files. The
   python-nfc.mk file was changed to use this setup.py standard build
   process.]

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-nfc/Config.in [new file with mode: 0644]
package/python-nfc/python-nfc-add-setup-py.patch [new file with mode: 0644]
package/python-nfc/python-nfc.mk [new file with mode: 0644]

index d0daa186d72273ee29903a8783e5ee8c918d935e..46747d96b31bf83bd99d6adae7498a59054d6461 100644 (file)
@@ -269,6 +269,7 @@ source "package/python-dpkt/Config.in"
 source "package/python-id3/Config.in"
 source "package/python-mad/Config.in"
 source "package/python-netifaces/Config.in"
+source "package/python-nfc/Config.in"
 source "package/python-pygame/Config.in"
 source "package/python-serial/Config.in"
 source "package/python-setuptools/Config.in"
diff --git a/package/python-nfc/Config.in b/package/python-nfc/Config.in
new file mode 100644 (file)
index 0000000..c928ba1
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_NFC
+       bool "python-nfc"
+       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_LIBUSB
+       select BR2_PACKAGE_LIBUSB_COMPAT
+       help
+         Python module for near field communication.
+
+         https://launchpad.net/nfcpy
diff --git a/package/python-nfc/python-nfc-add-setup-py.patch b/package/python-nfc/python-nfc-add-setup-py.patch
new file mode 100644 (file)
index 0000000..307b749
--- /dev/null
@@ -0,0 +1,26 @@
+Add simple setup.py
+
+Having a setup.py allows to easily get the .py files compiled into
+.pyc, which is good because by default, Buildroot only keeps .pyc
+files on the target.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/setup.py
+===================================================================
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,13 @@
++#!/usr/bin/env python
++
++from distutils.core import setup
++
++setup(name='NFC',
++      version='1.0',
++      description='Python NFC',
++      author='Stephen Tiedemann',
++      author_email='stephen.tiedemann@googlemail.com',
++      url='https://launchpad.net/nfcpy',
++      packages=['nfc', 'nfc/dev', 'nfc/llcp', 'nfc/ndef',
++                'nfc/npp', 'nfc/snep'],
++      )
diff --git a/package/python-nfc/python-nfc.mk b/package/python-nfc/python-nfc.mk
new file mode 100644 (file)
index 0000000..90f7c46
--- /dev/null
@@ -0,0 +1,23 @@
+#############################################################
+#
+# python-nfc
+#
+#############################################################
+PYTHON_NFC_VERSION = 112
+PYTHON_NFC_SITE = https://launchpad.net/nfcpy
+PYTHON_NFC_SITE_METHOD = bzr
+PYTHON_NFC_DEPENDENCIES = python libusb libusb-compat
+
+define PYTHON_NFC_BUILD_CMDS
+       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_NFC_INSTALL_TARGET_CMDS
+       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+define PYTHON_NFC_UNINSTALL_TARGET_CMDS
+       $(RM) -r $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/nfc/
+endef
+
+$(eval $(generic-package))