Makefile: use /etc/os-release for version info rather than /etc/br-version
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 14 Feb 2012 11:58:25 +0000 (12:58 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 14 Feb 2012 12:08:23 +0000 (13:08 +0100)
/etc/os-release is becoming a standard interface for distribution
name/version info, so let's use that instead of the nonstandard
/etc/br-version. Format of the file is something like:

NAME=Buildroot
VERSION=2012.02-rc1-00003-g2d10e81
ID=buildroot
VERSION_ID=2012.02-rc1
PRETTY_NAME="Buildroot 2012.02-rc1"

For more details, see:

http://0pointer.de/public/systemd-man/os-release.html

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 7d8dd2ed2eb6cdc8b133666f5a8817686cbf99a1..8a8b6760cb3e7cfbcd3ffb224140721f407fef61 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -477,7 +477,13 @@ endif
        else \
                /sbin/ldconfig -r $(TARGET_DIR); \
        fi
-       echo $(BR2_VERSION_FULL) > $(TARGET_DIR)/etc/br-version
+       ( \
+               echo "NAME=Buildroot"; \
+               echo "VERSION=$(BR2_VERSION_FULL)"; \
+               echo "ID=buildroot"; \
+               echo "VERSION_ID=$(BR2_VERSION)"; \
+               echo "PRETTY_NAME=\"Buildroot $(BR2_VERSION)\"" \
+       ) >  $(TARGET_DIR)/etc/os-release
 
 ifneq ($(BR2_ROOTFS_POST_BUILD_SCRIPT),"")
        $(BR2_ROOTFS_POST_BUILD_SCRIPT) $(TARGET_DIR)