package/kodi: Add suboption to control MySQL support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 11 Jul 2016 18:09:02 +0000 (20:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Jul 2016 12:32:01 +0000 (14:32 +0200)
In a Buildroot configuration with mysql enabled it might be useful to
be able to build Kodi without mysql support because Kodi may not need
it at runtime.

Kodi can store its internal databases not only locally using sqlite
but also on a mysql server, this allows several local Kodi machines to
share the same databases. When using only one Kodi instance, mysql
support is not needed, and not building mysql support helps reducing
build time.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index afb834ecd7602e962fd15ba8c011a75868f21df7..f388a724c1d769b1cce644515cce1c61d39c9aa3 100644 (file)
@@ -174,6 +174,12 @@ config BR2_PACKAGE_KODI_LIBNFS
 comment "nfs support needs a toolchain w/ threads support"
        depends on !(BR2_TOOLCHAIN_HAS_THREADS || BR2_TOOLCHAIN_HAS_NATIVE_RPC)
 
+config BR2_PACKAGE_KODI_MYSQL
+       bool "mysql"
+       select BR2_PACKAGE_MYSQL
+       help
+         Enable MySQL support
+
 config BR2_PACKAGE_KODI_NONFREE
        bool "nonfree components"
        help
index 9f21bf2988ac63dcbfdb63e3f5363a9a7a1fc94e..e0361dae781b343d692d4fa24df2a62fe465c115 100644 (file)
@@ -77,7 +77,7 @@ KODI_CONF_OPTS +=  \
        --disable-vtbdecoder \
        --enable-optimizations
 
-ifeq ($(BR2_PACKAGE_MYSQL),y)
+ifeq ($(BR2_PACKAGE_KODI_MYSQL),y)
 KODI_CONF_OPTS += --enable-mysql
 KODI_CONF_ENV += ac_cv_path_MYSQL_CONFIG="$(STAGING_DIR)/usr/bin/mysql_config"
 KODI_DEPENDENCIES += mysql