package/postgresql: fix build with NLS
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 20 Apr 2019 13:35:51 +0000 (15:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Apr 2019 14:11:26 +0000 (16:11 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/0d35378b8bdcfffb0cefd264c95ca3617034559b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/postgresql/postgresql.mk

index c7e9f526fc805aeee0469b0407e98d03b9b69ff0..8f01460109d22c6cdfffd4a98294ba03e0a3e69e 100644 (file)
@@ -14,8 +14,10 @@ POSTGRESQL_CONFIG_SCRIPTS = pg_config
 POSTGRESQL_CONF_ENV = \
        ac_cv_type_struct_sockaddr_in6=yes \
        pgac_cv_snprintf_long_long_int_modifier="ll" \
-       pgac_cv_snprintf_size_t_support=yes
+       pgac_cv_snprintf_size_t_support=yes \
+       LIBS=$(TARGET_NLS_LIBS)
 POSTGRESQL_CONF_OPTS = --disable-rpath
+POSTGRESQL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 
 # https://www.postgresql.org/docs/11/static/install-procedure.html:
 # "If you want to invoke the build from another makefile rather than