mdadm: also install mdmon
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Oct 2018 20:00:56 +0000 (22:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Oct 2018 05:21:13 +0000 (07:21 +0200)
This commit adjusts the mdadm package to also install the mdmon
utility, which is used to "monitor MD external metadata arrays". It
adds ~250 KB to the installed size:

-rwxr-xr-x 1 thomas thomas 446064 Oct 14 21:55 mdadm
-rwxr-xr-x 1 thomas thomas 244672 Oct 14 21:55 mdmon

Fixes bug #11376.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mdadm/mdadm.mk

index bdf77fcd56d4e7baf60fc4f4fa6f6ef497f2503a..3ee4ddd059e9a7f384696f240afab6ac38b86251 100644 (file)
@@ -16,13 +16,13 @@ define MDADM_BUILD_CMDS
                CFLAGS="$(TARGET_CFLAGS) -DNO_COROSYNC -DNO_DLM" \
                CPPFLAGS="$(TARGET_CPPFLAGS) -DBINDIR=\\\"/sbin\\\"" \
                CHECK_RUN_DIR=0 \
-               mdadm
+               mdadm mdmon
 endef
 
 define MDADM_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
                DESTDIR=$(TARGET_DIR) \
-               install-mdadm
+               install-mdadm install-mdmon
 endef
 
 $(eval $(generic-package))