target-g++: fix build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Jul 2010 20:32:02 +0000 (22:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Jul 2010 20:32:02 +0000 (22:32 +0200)
Just as we did to fix target-gcc, pass CXX_FOR_TARGET when building
target g++, and remove useless copies of g++ and c++.

Tested on ARM by compiling a simple C++ program using <iostream> on
the target and running it.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gcc/gcc-uclibc-4.x.mk

index 9720ed39b4bcf0be3d298a56de077d48f4c3cf08..6e767ac77554f74f194beef5a9b152b6c66517d0 100644 (file)
@@ -399,6 +399,7 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.prepared
                BOOT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_SOFT_FLOAT)" \
                GCC_FOR_TARGET="$(TARGET_CC)" \
                CC_FOR_TARGET="$(TARGET_CC)" \
+               CXX_FOR_TARGET="$(TARGET_CXX)" \
                $(GCC_SRC_DIR)/configure $(QUIET) \
                --prefix=/usr \
                --build=$(GNU_HOST_NAME) \
@@ -445,8 +446,10 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        # Remove broken specs file (cross compile flag is set).
        rm -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/specs
 
-       # Remove useless copies of gcc
+       # Remove useless copies of gcc, c++, g++
        rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc*
+       rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-g++*
+       rm -f $(TARGET_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-c++*
 
        # Work around problem of missing syslimits.h
        if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h ]; then \