package: add jsmin (javascript minimizer)
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 19 Dec 2011 14:53:40 +0000 (15:53 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Dec 2011 10:23:53 +0000 (11:23 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/jsmin/Config.in [new file with mode: 0644]
package/jsmin/jsmin.mk [new file with mode: 0644]

index 1c62ea37eb7389fbbb4c968504b805713dcb0ee4..adebd4be76d2a1b9a78c8c116827f079d20770ee 100644 (file)
@@ -328,6 +328,7 @@ source "package/flot/Config.in"
 source "package/jquery/Config.in"
 source "package/jquery-sparkline/Config.in"
 source "package/jquery-validation/Config.in"
+source "package/jsmin/Config.in"
 endmenu
 
 menu "Networking"
diff --git a/package/jsmin/Config.in b/package/jsmin/Config.in
new file mode 100644 (file)
index 0000000..d0948b8
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_JSMIN
+       bool "jsmin"
+       help
+         JSMin is a filter which removes comments and unnecessary
+         whitespace from JavaScript files. It typically reduces
+         filesize by half, resulting in faster downloads. It also
+         encourages a more expressive programming style because it
+         eliminates the download cost of clean, literate
+         self-documentation.
+
+         http://www.crockford.com/javascript/jsmin.html
diff --git a/package/jsmin/jsmin.mk b/package/jsmin/jsmin.mk
new file mode 100644 (file)
index 0000000..1c414ff
--- /dev/null
@@ -0,0 +1,25 @@
+JSMIN_VERSION = a9b47554d5684a55301a2eb7ca8480b7ee7630d4
+JSMIN_SITE = git://github.com/douglascrockford/JSMin.git
+
+define JSMIN_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) jsmin
+endef
+
+define JSMIN_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/jsmin $(TARGET_DIR)/usr/bin/jsmin
+endef
+
+define INPUT_EVENT_DAEMON_UNINSTALL_TARGET_CMDS
+       rm -f $(TARGET_DIR)/usr/bin/jsmin
+endef
+
+define HOST_JSMIN_BUILD_CMDS
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) jsmin
+endef
+
+define HOST_JSMIN_INSTALL_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/jsmin $(HOST_DIR)/usr/bin/jsmin
+endef
+
+$(eval $(call GENTARGETS))
+$(eval $(call GENTARGETS,host))