ffmpeg: fix build with gpl suboption and openssl
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 12:11:39 +0000 (13:11 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 12:11:39 +0000 (13:11 +0100)
Openssl's license isn't compatible with GPL, so ffmpeg's configure script
only allows this combination if nonfree is enabled.

Fixes http://autobuild.buildroot.net/results/ed6/ed6129d584229ebe4a0b291bc6a1dd0be23cc92a/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 2168785246449bcf86f28c79832a44eb774554d0..e60ced740b6a28d0467236526a53471a6e8aec53 100644 (file)
@@ -198,8 +198,13 @@ FFMPEG_CONF_OPT += --disable-bzlib
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
+# openssl isn't license compatible with GPL
+ifeq ($(BR2_PACKAGE_FFMPEG_GPL)x$(BR2_PACKAGE_FFMPEG_NONFREE),yx)
+FFMPEG_CONF_OPT += --disable-openssl
+else
 FFMPEG_CONF_OPT += --enable-openssl
 FFMPEG_DEPENDENCIES += openssl
+endif
 else
 FFMPEG_CONF_OPT += --disable-openssl
 endif