weston: handle dbus dependency
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Mar 2016 14:39:06 +0000 (11:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 15:00:51 +0000 (17:00 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/weston.mk

index 363a2bf67acdbae12e623eb98ed865bbc238ef71..72190a8c563754a907ecb7dda9cb75c504a10f59 100644 (file)
@@ -26,6 +26,13 @@ WESTON_CONF_OPTS = \
 WESTON_MAKE_OPTS = \
        WAYLAND_PROTOCOLS_DATADIR=$(STAGING_DIR)/usr/share/wayland-protocols
 
+ifeq ($(BR2_PACKAGE_DBUS),y)
+WESTON_CONF_OPTS += --enable-dbus
+WESTON_DEPENDENCIES += dbus
+else
+WESTON_CONF_OPTS += --disable-dbus
+endif
+
 # weston-launch must be u+s root in order to work properly
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 define WESTON_PERMISSIONS