package/bind: drop unneeded static openssl workarounds
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 13 Apr 2019 15:04:53 +0000 (17:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 13 Apr 2019 19:15:42 +0000 (21:15 +0200)
bind can't be built statically since commit
6045904752b06a8b8e52ba8fc2e49a8548964e8d

So drop uneeded LIBS="-lz" which was added by commit
80ebf12906afc3a1e5f4e5682d4c5dc0779a556a to fix static build with
openssl

Also, drop ac_cv_func_EVP_{sha256,sha384,sha512} that was also added to
fix tests in static build by commit
26aefa672c96caefc17adf59a9ab3d327114ad36

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bind/bind.mk

index 572eacd11ac20b54e22edfe50a5e4d14e41af896..b2bbafab20ef48599b044ca86d308a82eea1b8c4 100644 (file)
@@ -55,12 +55,8 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 BIND_DEPENDENCIES += openssl
-BIND_CONF_ENV += \
-       ac_cv_func_EVP_sha256=yes \
-       ac_cv_func_EVP_sha384=yes \
-       ac_cv_func_EVP_sha512=yes
 BIND_CONF_OPTS += \
-       --with-openssl=$(STAGING_DIR)/usr LIBS="-lz" \
+       --with-openssl=$(STAGING_DIR)/usr \
        --with-ecdsa=yes \
        --with-eddsa=no \
        --with-aes=yes