Use BR2_ENDIAN for big/little endianness detection
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 12 Jun 2007 15:30:32 +0000 (15:30 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 12 Jun 2007 15:30:32 +0000 (15:30 -0000)
target/cramfs/cramfs.mk
target/squashfs/squashfsroot.mk

index 54a0fa84561a3b52cae885c9feec50c886c5a71d..334048cd4f5bf4c82713fc56c8e1174bc030d84e 100644 (file)
@@ -39,24 +39,10 @@ cramfs-dirclean:
 # Build the cramfs root filesystem image
 #
 #############################################################
-CRAMFS_ENDIANNESS=-l
-ifeq ($(strip $(BR2_armeb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_mips)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-CRAMFS_ENDIANNESS=-b
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
 CRAMFS_ENDIANNESS=-b
+else
+CRAMFS_ENDIANNESS=-l
 endif
 
 CRAMFS_TARGET=$(IMAGE).cramfs
index 515153a0a2f7f8612245c2e15af003e361524e08..c9eb743276b435d2d7b2573e5622616af1b88078 100644 (file)
@@ -35,24 +35,10 @@ squashfs-dirclean:
 # Build the squashfs root filesystem image
 #
 #############################################################
-SQUASHFS_ENDIANNESS=-le
-ifeq ($(strip $(BR2_armeb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_mips)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_powerpc)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh3eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sh4eb)),y)
-SQUASHFS_ENDIANNESS=-be
-endif
-ifeq ($(strip $(BR2_sparc)),y)
+ifeq ($(BR2_ENDIAN),"BIG")
 SQUASHFS_ENDIANNESS=-be
+else
+SQUASHFS_ENDIANNESS=-le
 endif
 
 SQUASHFS_TARGET:=$(IMAGE).squashfs