libungif: remove deprecated
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 20 Jan 2016 16:53:40 +0000 (13:53 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 20 Jan 2016 20:14:10 +0000 (21:14 +0100)
It's been deprecated for a year now, so remove it.
While at it also remove the BR2_DEPRECATED_SINCE_2015_02 since it's now
unused.
And change the efl gif text to refer to giflib rather than libungif
which is what's used since it was deprecated.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in
package/Config.in
package/efl/Config.in
package/libungif/Config.in [deleted file]
package/libungif/libungif.hash [deleted file]
package/libungif/libungif.mk [deleted file]

index 63feef85984e0f745bca16a5f0908e8875f5bf73..30e88e3a3ce3b9c3fbddb2f56156efd32029f797 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -349,10 +349,6 @@ config BR2_DEPRECATED
 
 if BR2_DEPRECATED
 
-config BR2_DEPRECATED_SINCE_2015_02
-       bool
-       default y
-
 config BR2_DEPRECATED_SINCE_2015_05
        bool
        default y
index 3470643a91df5c71925ce91d3276d6146c2f102b..8883bbf36ff7ba8ca2f23cc798570bc0965bca4f 100644 (file)
@@ -890,7 +890,6 @@ menu "Graphics"
        source "package/libsvg/Config.in"
        source "package/libsvg-cairo/Config.in"
        source "package/libsvgtiny/Config.in"
-       source "package/libungif/Config.in"
        source "package/libva/Config.in"
        source "package/libva-intel-driver/Config.in"
        source "package/libvips/Config.in"
index fd3498e6deff029a1ec20386f7f8c2ffe0444093..85e46b1a6d94eedde4094c882112d607e953ba0c 100644 (file)
@@ -164,7 +164,7 @@ config BR2_PACKAGE_EFL_GIF
        select BR2_PACKAGE_GIFLIB
        help
          This enables the loader code that loads gif files using
-         libungif.
+         giflib.
 
 config BR2_PACKAGE_EFL_TIFF
        bool "libevas tiff loader"
diff --git a/package/libungif/Config.in b/package/libungif/Config.in
deleted file mode 100644 (file)
index 012ef76..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_LIBUNGIF
-       bool "libungif"
-       depends on !BR2_PACKAGE_GIFLIB
-       depends on BR2_DEPRECATED_SINCE_2015_02 # giflib
-       help
-         libungif is a library for handling the uncompressed GIF image format.
-
-         http://sourceforge.net/projects/libungif
diff --git a/package/libungif/libungif.hash b/package/libungif/libungif.hash
deleted file mode 100644 (file)
index 979b045..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed:
-sha256  708a7eac218d3fd8e8dfb13f1089d4e1e98246985180a17d6ecfca5a6bd4d332  libungif-4.1.4.tar.bz2
diff --git a/package/libungif/libungif.mk b/package/libungif/libungif.mk
deleted file mode 100644 (file)
index be9f646..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-################################################################################
-#
-# libungif
-#
-################################################################################
-
-LIBUNGIF_VERSION = 4.1.4
-LIBUNGIF_SOURCE = libungif-$(LIBUNGIF_VERSION).tar.bz2
-LIBUNGIF_SITE = http://downloads.sourceforge.net/project/giflib/libungif-4.x/libungif-$(LIBUNGIF_VERSION)
-LIBUNGIF_INSTALL_STAGING = YES
-LIBUNGIF_CONF_OPTS = --without-x
-LIBUNGIF_LICENSE = MIT
-LIBUNGIF_LICENSE_FILES = COPYING
-
-LIBUNGIF_BINS = \
-       gif2epsn gif2ps gif2rgb gif2x11 gifasm gifbg gifburst gifclip \
-       gifclrmp gifcolor gifcomb gifcompose giffiltr giffix gifflip  \
-       gifhisto gifinfo gifinter gifinto gifovly gifpos gifrotat     \
-       gifrsize gifspnge giftext gifwedge icon2gif raw2gif rgb2gif   \
-       text2gif
-
-define LIBUNGIF_BINS_CLEANUP
-       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,$(LIBUNGIF_BINS))
-endef
-
-LIBUNGIF_POST_INSTALL_TARGET_HOOKS += LIBUNGIF_BINS_CLEANUP
-
-$(eval $(autotools-package))