package/libfuse3: new package
authorAsaf Kahlon <asafka7@gmail.com>
Fri, 17 Apr 2020 13:18:55 +0000 (16:18 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 19 Apr 2020 13:01:29 +0000 (15:01 +0200)
The package is separated from the regular libfuse package, as it
contains new API (and can co-exist with libfuse).

Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/libfuse3/Config.in [new file with mode: 0644]
package/libfuse3/libfuse3.hash [new file with mode: 0644]
package/libfuse3/libfuse3.mk [new file with mode: 0644]

index a13a1694ea1d080091305150493869c9ec9f1dff..68b3f6a5c462b47c5fa79d9f46e26aad0367c7d9 100644 (file)
@@ -259,6 +259,7 @@ F:  configs/raspberrypi4_64_defconfig
 
 N:     Asaf Kahlon <asafka7@gmail.com>
 F:     package/collectd/
+F:     package/libfuse3/
 F:     package/libuv/
 F:     package/python*
 F:     package/snmpclitools/
index 55634e9479742fc45d7416154e43c8f24f08b363..46d3c75ee2b4c4d7ed5a2662e47b7a3fe16dac3f 100644 (file)
@@ -1359,6 +1359,7 @@ menu "Filesystem"
        source "package/libconfig/Config.in"
        source "package/libconfuse/Config.in"
        source "package/libfuse/Config.in"
+       source "package/libfuse3/Config.in"
        source "package/liblockfile/Config.in"
        source "package/libnfs/Config.in"
        source "package/libsysfs/Config.in"
diff --git a/package/libfuse3/Config.in b/package/libfuse3/Config.in
new file mode 100644 (file)
index 0000000..584d3bf
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBFUSE3
+       bool "libfuse3"
+       depends on !BR2_STATIC_LIBS
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       help
+         The reference implementation of the Linux FUSE
+         (Filesystem in Userspace) interface.
+
+         https://github.com/libfuse/libfuse
+
+comment "libfuse3 needs a toolchain w/ threads, dynamic library"
+       depends on BR2_USE_MMU
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
diff --git a/package/libfuse3/libfuse3.hash b/package/libfuse3/libfuse3.hash
new file mode 100644 (file)
index 0000000..bc09da4
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated sha256 checksums
+sha256  4f3dea4979c30fbd85f46b8812bee5945bd6bb4487165eb01ecde57bbfbb332f  libfuse3-3.9.1.tar.gz
+sha256  b8832d9caaa075bbbd2aef24efa09f8b7ab66a832812d88c602da0c7b4397fad  LICENSE
diff --git a/package/libfuse3/libfuse3.mk b/package/libfuse3/libfuse3.mk
new file mode 100644 (file)
index 0000000..d23d8d9
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# libfuse3
+#
+################################################################################
+
+LIBFUSE3_VERSION = 3.9.1
+LIBFUSE3_SITE = $(call github,libfuse,libfuse,fuse-$(LIBFUSE3_VERSION))
+LIBFUSE3_LICENSE = LGPL-2.1
+LIBFUSE3_LICENSE_FILES = LICENSE
+LIBFUSE3_INSTALL_STAGING = YES
+LIBFUSE3_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+LIBFUSE3_CONF_OPTS = \
+       -Dexamples=false \
+       -Dudevrulesdir=/lib/udev/rules.d \
+       -Duseroot=false
+
+define LIBFUSE3_DEVICES
+       /dev/fuse  c  666  0  0  10  229  0  0  -
+endef
+
+define LIBFUSE3_PERMISSIONS
+       /usr/bin/fusermount3 f 4755 0 0 - - - - -
+endef
+
+$(eval $(meson-package))