package/libsepol: change policy version to an int
authorAdam Duskett <aduskett@gmail.com>
Mon, 3 Feb 2020 13:29:50 +0000 (05:29 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 3 Feb 2020 15:49:33 +0000 (16:49 +0100)
The policy version has to be a number, as such, set the type to int.

Due to the type change, we can't any longer do the legacy handling of
re-using the refpolicy policy version.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libsepol/Config.in
package/refpolicy/refpolicy.mk

index 049c915c36c7c48add3623f24c17791f42bff2ad..3b84c907614a40c2db35cfcee308f61c7715dcec 100644 (file)
@@ -10,9 +10,8 @@ config BR2_PACKAGE_LIBSEPOL
 if BR2_PACKAGE_LIBSEPOL
 
 config BR2_PACKAGE_LIBSEPOL_POLICY_VERSION
-       string "Policy version"
-       default BR2_PACKAGE_REFPOLICY_POLICY_VERSION if BR2_PACKAGE_REFPOLICY_POLICY_VERSION != ""
-       default "30"
+       int "Policy version"
+       default 30
 
 endif
 
index 3f421e2ac14fbd4c1df55ebb8727d17c26477b86..1a5fefff0681f3606fb3a7c5c96c4535c483fb81 100644 (file)
@@ -25,8 +25,7 @@ REFPOLICY_MAKE = \
        $(TARGET_MAKE_ENV) \
        $(MAKE1)
 
-REFPOLICY_POLICY_VERSION = \
-       $(call qstrip,$(BR2_PACKAGE_LIBSEPOL_POLICY_VERSION))
+REFPOLICY_POLICY_VERSION = $(BR2_PACKAGE_LIBSEPOL_POLICY_VERSION)
 REFPOLICY_POLICY_STATE = \
        $(call qstrip,$(BR2_PACKAGE_REFPOLICY_POLICY_STATE))