MIPS: replace every BR2_mips_* with the new MIPS CPU options
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 30 Sep 2016 09:36:49 +0000 (10:36 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Oct 2016 11:22:17 +0000 (13:22 +0200)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
15 files changed:
package/binutils/Config.in.host
package/gcc/Config.in.host
package/glibc/glibc.mk
package/gmp/gmp.mk
package/go/Config.in.host
package/gstreamer/gst-ffmpeg/Config.in
package/luajit/Config.in
package/mbedtls/mbedtls.mk
package/mongrel2/mongrel2.mk
package/nodejs/nodejs.mk
package/openblas/Config.in
package/polarssl/polarssl.mk
package/uclibc/Config.in
toolchain/toolchain-buildroot/Config.in
toolchain/toolchain-external/Config.in

index 5ea5f31088f775b9ea5bcb594b1bc73006399e66..889d8ceff3a30566968b319c4489e6c627801b9f 100644 (file)
@@ -12,7 +12,7 @@ choice
                # supported, but broken on Nios-II, Blackfin and powerpc64le
                depends on !BR2_nios2 && !BR2_powerpc64le && !BR2_bfin
                # Unsupported for MIPS R6
-               depends on !BR2_mips_32r6 && !BR2_mips_64r6
+               depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
                # Unsupported ARM cores
                depends on !BR2_cortex_a17
                bool "binutils 2.24"
index 5b847fae6fae6e721364ad77e42ab1adf2430f3f..3c4d1cd280d1ca0d17368254b94c960bfd0ca296 100644 (file)
@@ -29,7 +29,7 @@ choice
                # Broken or unsupported x86 cores
                depends on !BR2_x86_jaguar && !BR2_x86_steamroller
                # Unsupported for MIPS R6
-               depends on !BR2_mips_32r6 && !BR2_mips_64r6
+               depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
                # musl ppc64 unsupported
                depends on !(BR2_TOOLCHAIN_USES_MUSL && (BR2_powerpc64 || BR2_powerpc64el))
                select BR2_GCC_NEEDS_MPC
@@ -47,7 +47,7 @@ choice
                # gcc-4.8.x + binutils-2.25 is broken for MIPS
                depends on !((BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el) && BR2_BINUTILS_VERSION_2_25_X)
                # Unsupported for MIPS R6
-               depends on !BR2_mips_32r6 && !BR2_mips_64r6
+               depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
                # musl ppc64 unsupported
                depends on !(BR2_TOOLCHAIN_USES_MUSL && (BR2_powerpc64 || BR2_powerpc64el))
                # musl mips64 unsupported
@@ -71,7 +71,7 @@ choice
                # Broken or unsupported ARM cores
                depends on !BR2_cortex_a17
                # Unsupported for MIPS R6
-               depends on !BR2_mips_32r6 && !BR2_mips_64r6
+               depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
                # musl ppc64 unsupported
                depends on !(BR2_TOOLCHAIN_USES_MUSL && (BR2_powerpc64 || BR2_powerpc64el))
                # musl mips64 unsupported
index 2c32e65fdce0e165f4c53b38701a06d5c177a38a..50154e851ad02c1ce46a9047922a23a63e22e9e6 100644 (file)
@@ -136,7 +136,7 @@ endef
 # highly unlikely. The failure mode, if it ever occurs, would be either
 # that a signalling NaN fails to raise an invalid operation exception or
 # (more likely) an ordinary NaN raises an invalid operation exception.
-ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
+ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
 define GLIBC_FIX_MIPS_R6
        $(SED) 's#10.0.0#4.0.0#' \
                $(@D)/sysdeps/unix/sysv/linux/mips/configure \
index 420fd2f3fd0bfb184bee928f665e99f41aca5f45..843a7a1781307f54b912fca5a1c9d145556668cd 100644 (file)
@@ -15,7 +15,7 @@ HOST_GMP_DEPENDENCIES = host-m4
 
 # GMP doesn't support assembly for coldfire or mips r6 ISA yet
 # Disable for ARM v7m since it has different asm constraints
-ifeq ($(BR2_m68k_cf)$(BR2_mips_32r6)$(BR2_mips_64r6)$(BR2_ARM_CPU_ARMV7M)$(BR2_arc),y)
+ifeq ($(BR2_m68k_cf)$(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6)$(BR2_ARM_CPU_ARMV7M)$(BR2_arc),y)
 GMP_CONF_OPTS += --disable-assembly
 endif
 
index d79c669e0ab953c178aa94b6e788ce4321ad7211..8d4d346bf3eedd7b629b367a1f03b822f61a8b78 100644 (file)
@@ -6,7 +6,7 @@ config BR2_PACKAGE_HOST_GO_ARCH_SUPPORTS
                || BR2_mips64 || BR2_mips64el
        depends on !BR2_ARM_CPU_ARMV4
        # MIPS R6 support in Go has not yet been developed.
-       depends on !BR2_mips_64r6
+       depends on !BR2_MIPS_CPU_MIPS64R6
 
 config BR2_PACKAGE_HOST_GO_CGO_LINKING_SUPPORTS
        bool
index f3d4b3e568d1c0b7bde8294ee9fa7f31062bc5df..2164ea2e053302ecd306370b9c33347a0c59eabf 100644 (file)
@@ -2,7 +2,7 @@ config BR2_PACKAGE_GST_FFMPEG
        bool "gst-ffmpeg"
        # Unsupported for MIPS R6. It bundles a version of libav which
        # doesn't have support for MIPS R6.
-       depends on !BR2_mips_32r6 && !BR2_mips_64r6
+       depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
        # triggers https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65151 on sh
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_5 || !BR2_sh
        select BR2_PACKAGE_GST_PLUGINS_BASE
index f9285e8a4743ea00b874ed26f3c0823778517100..380f2472ead7f9fdeae7e9e395e8be6f57c2d8ce 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
                (BR2_x86_64 && BR2_HOSTARCH='x86_64') || \
                BR2_powerpc || BR2_arm || BR2_armeb || \
                ((BR2_mips || BR2_mipsel) && !BR2_MIPS_SOFT_FLOAT && \
-               !BR2_mips_32r6 && !BR2_mips_64r6)
+               !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6)
 
 config BR2_PACKAGE_LUAJIT
        bool "luajit"
index 7067bebecd373290cbf32cf349d9c4100e96a36a..d55e16b0b65a97d2c0d48a64b4271703da0a37ca 100644 (file)
@@ -60,7 +60,7 @@ endef
 # MIPS R6 asm is not yet supported
 ifeq ($(BR2_ENABLE_DEBUG)$(BR2_ARM_INSTRUCTIONS_THUMB)$(BR2_ARM_INSTRUCTIONS_THUMB2),yy)
 MBEDTLS_POST_CONFIGURE_HOOKS += MBEDTLS_DISABLE_ASM
-else ifeq ($(BR2_microblaze)$(BR2_mips_32r6)$(BR2_mips_64r6),y)
+else ifeq ($(BR2_microblaze)$(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
 MBEDTLS_POST_CONFIGURE_HOOKS += MBEDTLS_DISABLE_ASM
 endif
 
index d0640c9680ba39efcd26edd019fc2a98bc6f3962..c69c14345f7e2967ccac9c529d6d51b2fce1a1e4 100644 (file)
@@ -24,7 +24,7 @@ ifeq ($(BR2_ENABLE_DEBUG)$(BR2_ARM_INSTRUCTIONS_THUMB)$(BR2_ARM_INSTRUCTIONS_THU
 MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
 else ifeq ($(BR2_microblaze),y)
 MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
-else ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
+else ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
 MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
 endif
 
index d6f115a51068cbfe1e532bbec2bebf54191f1816..81006f582fb1ec838832dbfb7f4a252dfbc5091e 100644 (file)
@@ -96,12 +96,12 @@ endif
 
 # MIPS architecture specific options
 ifeq ($(BR2_mips)$(BR2_mipsel),y)
-ifeq ($(BR2_mips_32r6),y)
+ifeq ($(BR2_MIPS_CPU_MIPS32R6),y)
 NODEJS_MIPS_ARCH_VARIANT = r6
 NODEJS_MIPS_FPU_MODE = fp64
-else ifeq ($(BR2_mips_32r2),y)
+else ifeq ($(BR2_MIPS_CPU_MIPS32R2),y)
 NODEJS_MIPS_ARCH_VARIANT = r2
-else ifeq ($(BR2_mips_32),y)
+else ifeq ($(BR2_MIPS_CPU_MIPS32),y)
 NODEJS_MIPS_ARCH_VARIANT = r1
 endif
 endif
index 0609a91e54a006238f76c5d2e2b6bcdb85e49968..1fbed1c27ab3df52d429466d45511215cf2350bc 100644 (file)
@@ -27,10 +27,10 @@ config BR2_PACKAGE_OPENBLAS_DEFAULT_TARGET
        default "PPC440"       if BR2_powerpc_440
        default "PPC440FP2"    if BR2_powerpc_440fp
        # P5600 is built with MSA support which is only available in Codescape toolchains
-       default "P5600"        if BR2_mips_32r2 && BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_MTI_MIPS
-       default "SICORTEX"     if BR2_mips_64
+       default "P5600"        if BR2_MIPS_CPU_MIPS32R2 && BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_MTI_MIPS
+       default "SICORTEX"     if BR2_MIPS_CPU_MIPS64
        # I6400 is built with MSA support which is only available in Codescape toolchains
-       default "I6400"        if BR2_mips_64r6 && BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_IMG_MIPS
+       default "I6400"        if BR2_MIPS_CPU_MIPS64R6 && BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_IMG_MIPS
        default "SPARC"        if BR2_sparc
        # Cortex-A15 always have a VFPv4
        default "CORTEXA15"    if (BR2_cortex_a15 && BR2_ARM_EABIHF)
index 9199f28a07b3009c1bb95db863b487115647ee44..7f4c5827a057bf83b0a14ef7b337f3bac6ade579 100644 (file)
@@ -25,7 +25,7 @@ ifeq ($(BR2_ENABLE_DEBUG)$(BR2_ARM_INSTRUCTIONS_THUMB)$(BR2_ARM_INSTRUCTIONS_THU
 POLARSSL_POST_CONFIGURE_HOOKS += POLARSSL_DISABLE_ASM
 else ifeq ($(BR2_microblaze),y)
 POLARSSL_POST_CONFIGURE_HOOKS += POLARSSL_DISABLE_ASM
-else ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
+else ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
 POLARSSL_POST_CONFIGURE_HOOKS += POLARSSL_DISABLE_ASM
 endif
 
index 33969cc1ce6cbb7a715231c21a2cb19a3155a94d..cbae096d6c93f880b3f78fc881db6cbc393419f9 100644 (file)
@@ -145,9 +145,9 @@ config BR2_UCLIBC_MIPS_ABI
 config BR2_UCLIBC_MIPS_ISA
        string
        depends on BR2_UCLIBC_TARGET_ARCH = "mips"
-       default "MIPS32" if BR2_mips_32
-       default "MIPS32R2" if BR2_mips_32r2
-       default "MIPS64" if BR2_mips_64
+       default "MIPS32" if BR2_MIPS_CPU_MIPS32
+       default "MIPS32R2" if BR2_MIPS_CPU_MIPS32R2
+       default "MIPS64" if BR2_MIPS_CPU_MIPS64
 
 config BR2_UCLIBC_SH_TYPE
        string
index 8e275c22f26bcab5a778dedf97057643e0885f3c..310572e502a18e9fe09aef5a83eb1270e0b37749 100644 (file)
@@ -35,7 +35,7 @@ config BR2_TOOLCHAIN_BUILDROOT_UCLIBC
                   BR2_powerpc || BR2_sh2a   || BR2_sh4    || BR2_sh4eb    || \
                   BR2_sparc   || BR2_xtensa || BR2_x86_64
        # Unsupported for MIPS R6
-       depends on !BR2_mips_32r6 && !BR2_mips_64r6
+       depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
        help
          This option selects uClibc-ng as the C library for the
          cross-compilation toolchain.
@@ -74,7 +74,7 @@ config BR2_TOOLCHAIN_BUILDROOT_MUSL
                   BR2_sh         || BR2_x86_64
        depends on !BR2_powerpc_SPE # not supported, build breaks
        # Unsupported for MIPS R6
-       depends on !BR2_mips_32r6 && !BR2_mips_64r6
+       depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
        # sh2 nommu is supported by musl, but we don't have support
        # for it in Buildroot.
        depends on BR2_USE_MMU
index bcb42db6ba202a89727f329563220905121f1961..15095b6d03eb37f97f2f2858af6bc3219e6ad6df 100644 (file)
@@ -190,7 +190,7 @@ config BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV5TE
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS
        bool "Sourcery CodeBench MIPS 2016.05"
        depends on BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
-       depends on BR2_mips_32r2 || BR2_mips_64r2
+       depends on BR2_MIPS_CPU_MIPS32R2 || BR2_MIPS_CPU_MIPS64R2
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        depends on !BR2_MIPS_NABI32
        depends on !BR2_STATIC_LIBS
@@ -283,7 +283,7 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_IMG_MIPS
        bool "Codescape IMG GNU Linux Toolchain 2016.05"
        depends on BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
-       depends on BR2_mips_32r6 || (BR2_mips_64r6 && !BR2_MIPS_SOFT_FLOAT)
+       depends on BR2_MIPS_CPU_MIPS32R6 || (BR2_MIPS_CPU_MIPS64R6 && !BR2_MIPS_SOFT_FLOAT)
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
        select BR2_INSTALL_LIBSTDCPP
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
@@ -346,7 +346,7 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_MTI_MIPS
        bool "Codescape MTI GNU Linux Toolchain 2016.05"
        depends on BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
-       depends on BR2_mips_32r2 || (BR2_mips_64r2 && !BR2_MIPS_SOFT_FLOAT)
+       depends on BR2_MIPS_CPU_MIPS32R2 || (BR2_MIPS_CPU_MIPS64R2 && !BR2_MIPS_SOFT_FLOAT)
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
        select BR2_INSTALL_LIBSTDCPP
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
@@ -595,7 +595,7 @@ config BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS
                BR2_x86_64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        # Unsupported for MIPS R6
-       depends on !BR2_mips_32r6 && !BR2_mips_64r6
+       depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
        select BR2_TOOLCHAIN_EXTERNAL_MUSL
        select BR2_TOOLCHAIN_HAS_SSP
        select BR2_INSTALL_LIBSTDCPP