perl: use <pkg>_EXTRA_DOWNLOADS
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Mar 2015 17:33:21 +0000 (19:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 30 Mar 2015 21:40:12 +0000 (23:40 +0200)
Instead of manually using the DOWNLOAD macro (which should remain an
internal macro), this commit converts the Perl package to use
<pkg>_EXTRA_DOWNLOADS, now that it has been extended to allow full
URLs.

[Thomas: as suggested by Yann, keep comment explaining how we handle
perl-cross.]

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/perl/perl.mk

index 133e8aa1423ca907fc91ebd6c4a912fae3cdac98..afa908343ce9ad6a10131622d0ea01d77e3a4c0f 100644 (file)
@@ -17,6 +17,8 @@ PERL_CROSS_BASE_VERSION = 5.$(PERL_VERSION_MAJOR).2
 # DO NOT refactor with the github helper (the result is not the same)
 PERL_CROSS_SITE = http://raw.github.com/arsv/perl-cross/releases
 PERL_CROSS_SOURCE = perl-$(PERL_CROSS_BASE_VERSION)-cross-$(PERL_CROSS_VERSION).tar.gz
+PERL_EXTRA_DOWNLOADS = $(PERL_CROSS_SITE)/$(PERL_CROSS_SOURCE)
+
 PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_CROSS_BASE_VERSION))delta.pod
 PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
 
@@ -24,12 +26,6 @@ PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod
 # be extracted over the perl sources, so we don't define that
 # as a separate package. Instead, it is downloaded and extracted
 # together with perl
-
-define PERL_CROSS_DOWNLOAD
-       $(call DOWNLOAD,$(PERL_CROSS_SITE:/=)/$(PERL_CROSS_SOURCE))
-endef
-PERL_POST_DOWNLOAD_HOOKS += PERL_CROSS_DOWNLOAD
-
 define PERL_CROSS_EXTRACT
        $(call suitable-extractor,$(PERL_CROSS_SOURCE)) $(DL_DIR)/$(PERL_CROSS_SOURCE) | \
        $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -