package/clang: fix build with gcc < 5.1
authorValentin Korenblit <valentinkorenblit@gmail.com>
Mon, 15 Apr 2019 19:14:01 +0000 (21:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 15 Apr 2019 19:25:37 +0000 (21:25 +0200)
Fixes:
http://autobuild.buildroot.net/results/dc2302844a1d274e63da72023b6fd7be993f97b7

Signed-off-by: Valentin Korenblit <valentinkorenblit@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/clang/clang.mk

index 6dda8ac2c328b7753a13dfb7e90147f8348a07a9..0cab1c7f893bef9a3b07bd49611c6aead8cbae40 100644 (file)
@@ -15,6 +15,13 @@ CLANG_INSTALL_STAGING = YES
 HOST_CLANG_DEPENDENCIES = host-llvm host-libxml2
 CLANG_DEPENDENCIES = llvm host-clang
 
+# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
+# toolchain using gcc < 5.1 gives an error but actually still works. Setting
+# this option makes it still build with gcc >= 4.8.
+# https://reviews.llvm.org/D57264
+HOST_CLANG_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+CLANG_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+
 # This option is needed, otherwise multiple shared libs
 # (libclangAST.so, libclangBasic.so, libclangFrontend.so, etc.) will
 # be generated. As a final shared lib containing all these components