jasper: disable -pedantic-errors
authorBaruch Siach <baruch@tkos.co.il>
Sat, 12 Nov 2016 19:29:56 +0000 (21:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 13 Nov 2016 11:23:17 +0000 (12:23 +0100)
The -pedantic-errors gcc option turns -pedantic warnings into errors. This
mostly affects older gcc versions that default to the ISO90 C standard. Use
the --disable-strict configure option to remove -pedantic-errors.

Fixes:
http://autobuild.buildroot.net/results/191/191f80779df1a9e6f832106e6c4bdf601e2a9893/
http://autobuild.buildroot.net/results/1fe/1febccc7215814490fa3c776b34bc367363afe39/
http://autobuild.buildroot.net/results/a6f/a6f9bfec3406fc21b130f1669e3534651b9c9596/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/jasper/jasper.mk

index 4616fed1885dd2a6289c8b69b202013ddc7d1e09..bacb1a6cfebba43e0127335e11fc8fc4f6ac1af0 100644 (file)
@@ -10,6 +10,7 @@ JASPER_INSTALL_STAGING = YES
 JASPER_DEPENDENCIES = jpeg
 JASPER_LICENSE = JasPer License Version 2.0
 JASPER_LICENSE_FILES = LICENSE
+JASPER_CONF_OPTS = --disable-strict
 
 # Xtensa gcc is unable to generate correct code with -O0 enabled by
 # --enable-debug. Allow package build but disable debug.