lirc-tools: bump to version 0.9.4b
authorBaruch Siach <baruch@tkos.co.il>
Tue, 18 Oct 2016 20:06:52 +0000 (23:06 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 18 Oct 2016 20:21:03 +0000 (22:21 +0200)
Drop upstream patches. Renumber the rest.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/lirc-tools/0001-lib-use-proper-linking-method-to-avoid-parallel-buil.patch [deleted file]
package/lirc-tools/0001-tools-make_rel_symlink.py-can-also-use-python2.patch [new file with mode: 0644]
package/lirc-tools/0002-configure-check-for-clock_gettime-in-librt.patch [new file with mode: 0644]
package/lirc-tools/0002-tools-make_rel_symlink.py-can-also-use-python2.patch [deleted file]
package/lirc-tools/0003-Don-t-build-commandir-unless-we-have-usb.h-191.patch [deleted file]
package/lirc-tools/0003-lircd-Remove-use-of-functions-killed-in-kernel-4.8.0.patch [new file with mode: 0644]
package/lirc-tools/0004-configure-check-for-clock_gettime-in-librt.patch [deleted file]
package/lirc-tools/0005-lircd-Remove-use-of-functions-killed-in-kernel-4.8.0.patch [deleted file]
package/lirc-tools/lirc-tools.hash
package/lirc-tools/lirc-tools.mk

diff --git a/package/lirc-tools/0001-lib-use-proper-linking-method-to-avoid-parallel-buil.patch b/package/lirc-tools/0001-lib-use-proper-linking-method-to-avoid-parallel-buil.patch
deleted file mode 100644 (file)
index 5863128..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-From f2fc8c48e5e55a91b309225f377b6cb3783fc6f6 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Wed, 25 May 2016 15:21:57 +0200
-Subject: [PATCH] lib: use proper linking method to avoid parallel build issue
-
-Using <foo>_LDFLAGS = -l<library> is correct when <library> is an
-external library. However, when it is built by the same package, and
-especially in the same directory, this is wrong and can cause parallel
-build issues. In lib/Makefile.am, there was:
-
-libirrecord_la_LDFLAGS      = -llirc
-
-But the liblirc library is built in the same directory. Or, due to the
-using of <foo>_LDFLAGS, make is not aware of the build dependency
-between libirrecord and liblirc.
-
-To solve this, <foo>_LIBADD should be used instead, as follows:
-
-libirrecord_la_LIBADD       = liblirc.la
-
-This fixes parallel build issues seen by automated build tests
-conducted by the Buildroot project, such as:
-
-  http://autobuild.buildroot.org/results/eb4/eb47d57de8182d25b1dacbf0ac3726ed20063d04/build-end.log
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- lib/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/Makefile.am b/lib/Makefile.am
-index ce5c94c..8780f88 100644
---- a/lib/Makefile.am
-+++ b/lib/Makefile.am
-@@ -29,7 +29,7 @@ liblirc_la_SOURCES          = config_file.c \
-                               transmit.c \
-                               util.c
--libirrecord_la_LDFLAGS      = -llirc
-+libirrecord_la_LIBADD       = liblirc.la
- libirrecord_la_SOURCES      = irrecord.c
- liblirc_client_la_LDFLAGS   = -version-info 4:0:4
--- 
-2.7.4
-
diff --git a/package/lirc-tools/0001-tools-make_rel_symlink.py-can-also-use-python2.patch b/package/lirc-tools/0001-tools-make_rel_symlink.py-can-also-use-python2.patch
new file mode 100644 (file)
index 0000000..070aab9
--- /dev/null
@@ -0,0 +1,28 @@
+From c861eae83bae3116d330efb3c6061e2de4fdcbce Mon Sep 17 00:00:00 2001
+From: Baruch Siach <baruch@tkos.co.il>
+Date: Sun, 5 Apr 2015 22:26:12 +0300
+Subject: [PATCH] tools: make_rel_symlink.py can also use python2
+
+The make_rel_symlink.py script is compatible with both python2 and python3.
+Don't hard code a requirement for python3.
+
+Patch status: sent upstream
+
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+---
+ tools/make_rel_symlink.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/make_rel_symlink.py b/tools/make_rel_symlink.py
+index 896637ff93e0..ff0403a0397a 100755
+--- a/tools/make_rel_symlink.py
++++ b/tools/make_rel_symlink.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python3
++#!/usr/bin/env python
+ import os
+ import os.path
+-- 
+2.1.4
+
diff --git a/package/lirc-tools/0002-configure-check-for-clock_gettime-in-librt.patch b/package/lirc-tools/0002-configure-check-for-clock_gettime-in-librt.patch
new file mode 100644 (file)
index 0000000..710dfd3
--- /dev/null
@@ -0,0 +1,54 @@
+From e654ae139cec42a6f1b5684261787d0c241cfd3b Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Fri, 19 Aug 2016 15:25:48 +0200
+Subject: [PATCH] configure: check for clock_gettime in librt
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac        | 3 +++
+ daemons/Makefile.am | 2 +-
+ plugins/Makefile.am | 1 +
+ 3 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 73340c7..466e638 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -67,6 +67,9 @@ AC_CHECK_FUNCS(gethostname gettimeofday mkfifo select socket strdup \
+ AC_SEARCH_LIBS([dlopen], [dl dld], [], [
+   AC_MSG_ERROR([unable to find the dlopen() function])
+ ])
++# glibc < 2.17 needs librt for clock_gettime()
++AC_CHECK_LIB(rt, clock_gettime, LIBCLOCK_GETTIME="-lrt")
++AC_SUBST(LIBCLOCK_GETTIME)
+ AC_CHECK_FUNCS(daemon)
+ if test "$ac_cv_func_daemon" != yes; then
+   daemon=""
+diff --git a/daemons/Makefile.am b/daemons/Makefile.am
+index 5625627..85a28f3 100644
+--- a/daemons/Makefile.am
++++ b/daemons/Makefile.am
+@@ -21,7 +21,7 @@ sbin_PROGRAMS           += lircd-uinput
+ endif
+ lircd_SOURCES           = lircd.cpp
+-lircd_LDADD             = ../lib/liblirc.la
++lircd_LDADD             = ../lib/liblirc.la @LIBCLOCK_GETTIME@
+ lircd_uinput_SOURCES    = lircd-uinput.cpp
+ lircd_uinput_LDADD     = ../lib/liblirc.la
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index ddff01d..45c012a 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -127,6 +127,7 @@ zotac_la_SOURCES            = zotac.c
+ plugin_LTLIBRARIES          += mplay.la
+ mplay_la_SOURCES            = mplay.c
++mplay_la_LIBADD             = @LIBCLOCK_GETTIME@
+ endif
+ $(srcdir)/pluginlist.am:
+-- 
+2.7.4
+
diff --git a/package/lirc-tools/0002-tools-make_rel_symlink.py-can-also-use-python2.patch b/package/lirc-tools/0002-tools-make_rel_symlink.py-can-also-use-python2.patch
deleted file mode 100644 (file)
index 070aab9..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From c861eae83bae3116d330efb3c6061e2de4fdcbce Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Sun, 5 Apr 2015 22:26:12 +0300
-Subject: [PATCH] tools: make_rel_symlink.py can also use python2
-
-The make_rel_symlink.py script is compatible with both python2 and python3.
-Don't hard code a requirement for python3.
-
-Patch status: sent upstream
-
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
- tools/make_rel_symlink.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/make_rel_symlink.py b/tools/make_rel_symlink.py
-index 896637ff93e0..ff0403a0397a 100755
---- a/tools/make_rel_symlink.py
-+++ b/tools/make_rel_symlink.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python3
-+#!/usr/bin/env python
- import os
- import os.path
--- 
-2.1.4
-
diff --git a/package/lirc-tools/0003-Don-t-build-commandir-unless-we-have-usb.h-191.patch b/package/lirc-tools/0003-Don-t-build-commandir-unless-we-have-usb.h-191.patch
deleted file mode 100644 (file)
index a3f2f3b..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From f346045e0f63289909322a3264e69b967a911636 Mon Sep 17 00:00:00 2001
-From: Alec Leamas <leamas.alec@gmail.com>
-Date: Tue, 24 May 2016 19:56:09 +0200
-Subject: [PATCH] Don't build commandir unless we have usb.h (#191).
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-(backported from git master:
- https://sourceforge.net/p/lirc/git/ci/f346045e0f63289909322a3264e69b967a911636/tree/plugins/Makefile.am?diff=4b26eb383291576b3f56820c6cec5f6a75814807)
----
- plugins/Makefile.am | 14 +++++++++-----
- 1 file changed, 9 insertions(+), 5 deletions(-)
-
-diff --git a/plugins/Makefile.am b/plugins/Makefile.am
-index 3bd89ed..2116658 100644
---- a/plugins/Makefile.am
-+++ b/plugins/Makefile.am
-@@ -14,6 +14,7 @@ EXTRA_DIST                  = pluginlist.am make-pluginlist.sh
- plugin_LTLIBRARIES          =
- if BUILD_USB
-+
- plugin_LTLIBRARIES          += atilibusb.la
- atilibusb_la_SOURCES        = atilibusb.c
- atilibusb_la_LDFLAGS        = $(AM_LDFLAGS) @usb_libs@
-@@ -33,6 +34,14 @@ plugin_LTLIBRARIES          += srm7500libusb.la
- srm7500libusb_la_SOURCES    = srm7500libusb.c
- srm7500libusb_la_LDFLAGS    = $(AM_LDFLAGS) @usb_libs@
- srm7500libusb_la_CFLAGS     = $(AM_CFLAGS) $(LIBUSB_CFLAGS)
-+
-+if !BSD
-+plugin_LTLIBRARIES          += commandir.la
-+commandir_la_SOURCES        = commandir.c
-+commandir_la_LDFLAGS        = $(AM_LDFLAGS) @usb_libs@
-+commandir_la_CFLAGS         = $(AM_CFLAGS) $(LIBUSB_CFLAGS)
-+endif
-+
- endif
- if BUILD_FTDI
-@@ -99,11 +108,6 @@ if !BSD
- plugin_LTLIBRARIES          += default.la
- default_la_SOURCES          = default.c
--plugin_LTLIBRARIES          += commandir.la
--commandir_la_SOURCES        = commandir.c
--commandir_la_LDFLAGS        = $(AM_LDFLAGS) @usb_libs@
--commandir_la_CFLAGS         = $(AM_CFLAGS) $(LIBUSB_CFLAGS)
--
- plugin_LTLIBRARIES          += hiddev.la
- hiddev_la_SOURCES           = hiddev.c
--- 
-2.8.1
-
diff --git a/package/lirc-tools/0003-lircd-Remove-use-of-functions-killed-in-kernel-4.8.0.patch b/package/lirc-tools/0003-lircd-Remove-use-of-functions-killed-in-kernel-4.8.0.patch
new file mode 100644 (file)
index 0000000..9fe5256
--- /dev/null
@@ -0,0 +1,105 @@
+From 45c590f64dd79e8e1704d5c94ce3456a5cdbfa5f Mon Sep 17 00:00:00 2001
+From: Alec Leamas <leamas.alec@gmail.com>
+Date: Fri, 19 Aug 2016 04:48:02 +0200
+Subject: [PATCH] lircd: Remove use of functions killed in kernel 4.8.0
+
+From 4.8.0 the kernel no longer supports LIRC_NOTIFY_DECODE,
+LIRC_SETUP_START/LIRC_SETUP_END and several constants related
+to initiating filters. Remove corresponding calls from lircd.
+
+[baruch: move DRVCTL_NOTIFY_DECODE into lircd.cpp]
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+---
+Patch status: backported from upstream 31fcc8aa39f62c5c
+---
+ daemons/lircd.cpp | 53 ++++-------------------------------------------------
+ 1 file changed, 4 insertions(+), 49 deletions(-)
+
+diff --git a/daemons/lircd.cpp b/daemons/lircd.cpp
+index 782b6d3f8342..d778aa19308b 100644
+--- a/daemons/lircd.cpp
++++ b/daemons/lircd.cpp
+@@ -78,6 +78,8 @@
+ #define lirc_gid gid_t
+ #endif
++#define DRVCTL_NOTIFY_DECODE          7
++
+ #ifdef DARWIN
+ #include <mach/mach_time.h>
+ #define CLOCK_REALTIME 0
+@@ -462,50 +464,6 @@ static int setup_timeout(void)
+ }
+-static int setup_filter(void)
+-{
+-      int ret1, ret2;
+-      lirc_t min_pulse_supported = 0, max_pulse_supported = 0;
+-      lirc_t min_space_supported = 0, max_space_supported = 0;
+-
+-      if (!(curr_driver->features & LIRC_CAN_SET_REC_FILTER))
+-              return 1;
+-      if (curr_driver->drvctl_func(LIRC_GET_MIN_FILTER_PULSE,
+-                                   &min_pulse_supported) == -1 ||
+-          curr_driver->drvctl_func(LIRC_GET_MAX_FILTER_PULSE, &max_pulse_supported) == -1
+-          || curr_driver->drvctl_func(LIRC_GET_MIN_FILTER_SPACE, &min_space_supported) == -1
+-          || curr_driver->drvctl_func(LIRC_GET_MAX_FILTER_SPACE, &max_space_supported) == -1) {
+-              log_error("could not get filter range");
+-              log_perror_err(__func__);
+-      }
+-
+-      if (setup_min_pulse > max_pulse_supported)
+-              setup_min_pulse = max_pulse_supported;
+-      else if (setup_min_pulse < min_pulse_supported)
+-              setup_min_pulse = 0;    /* disable filtering */
+-
+-      if (setup_min_space > max_space_supported)
+-              setup_min_space = max_space_supported;
+-      else if (setup_min_space < min_space_supported)
+-              setup_min_space = 0;    /* disable filtering */
+-
+-      ret1 = curr_driver->drvctl_func(LIRC_SET_REC_FILTER_PULSE, &setup_min_pulse);
+-      ret2 = curr_driver->drvctl_func(LIRC_SET_REC_FILTER_SPACE, &setup_min_space);
+-      if (ret1 == -1 || ret2 == -1) {
+-              if (curr_driver->
+-                  drvctl_func(LIRC_SET_REC_FILTER,
+-                              setup_min_pulse < setup_min_space ? &setup_min_pulse : &setup_min_space) == -1) {
+-                      log_error("could not set filter");
+-                      log_perror_err(__func__);
+-                      return 0;
+-              }
+-      }
+-      return 1;
+-}
+-
+-
+-
+-
+ static int setup_hardware(void)
+ {
+       int ret = 1;
+@@ -514,10 +472,7 @@ static int setup_hardware(void)
+               if ((curr_driver->features & LIRC_CAN_SET_REC_CARRIER)
+                   || (curr_driver->features & LIRC_CAN_SET_REC_TIMEOUT)
+                   || (curr_driver->features & LIRC_CAN_SET_REC_FILTER)) {
+-                      (void)curr_driver->drvctl_func(LIRC_SETUP_START, NULL);
+-                      ret = setup_frequency() && setup_timeout()
+-                            && setup_filter();
+-                      (void)curr_driver->drvctl_func(LIRC_SETUP_END, NULL);
++                              ret = setup_frequency() && setup_timeout();
+               }
+       }
+       return ret;
+@@ -2162,7 +2117,7 @@ void loop(void)
+                       int reps;
+                       if (curr_driver->drvctl_func && (curr_driver->features & LIRC_CAN_NOTIFY_DECODE))
+-                              curr_driver->drvctl_func(LIRC_NOTIFY_DECODE, NULL);
++                              curr_driver->drvctl_func(DRVCTL_NOTIFY_DECODE, NULL);
+                       get_release_data(&remote_name, &button_name, &reps);
+-- 
+2.9.3
+
diff --git a/package/lirc-tools/0004-configure-check-for-clock_gettime-in-librt.patch b/package/lirc-tools/0004-configure-check-for-clock_gettime-in-librt.patch
deleted file mode 100644 (file)
index 710dfd3..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From e654ae139cec42a6f1b5684261787d0c241cfd3b Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Fri, 19 Aug 2016 15:25:48 +0200
-Subject: [PATCH] configure: check for clock_gettime in librt
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- configure.ac        | 3 +++
- daemons/Makefile.am | 2 +-
- plugins/Makefile.am | 1 +
- 3 files changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 73340c7..466e638 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -67,6 +67,9 @@ AC_CHECK_FUNCS(gethostname gettimeofday mkfifo select socket strdup \
- AC_SEARCH_LIBS([dlopen], [dl dld], [], [
-   AC_MSG_ERROR([unable to find the dlopen() function])
- ])
-+# glibc < 2.17 needs librt for clock_gettime()
-+AC_CHECK_LIB(rt, clock_gettime, LIBCLOCK_GETTIME="-lrt")
-+AC_SUBST(LIBCLOCK_GETTIME)
- AC_CHECK_FUNCS(daemon)
- if test "$ac_cv_func_daemon" != yes; then
-   daemon=""
-diff --git a/daemons/Makefile.am b/daemons/Makefile.am
-index 5625627..85a28f3 100644
---- a/daemons/Makefile.am
-+++ b/daemons/Makefile.am
-@@ -21,7 +21,7 @@ sbin_PROGRAMS           += lircd-uinput
- endif
- lircd_SOURCES           = lircd.cpp
--lircd_LDADD             = ../lib/liblirc.la
-+lircd_LDADD             = ../lib/liblirc.la @LIBCLOCK_GETTIME@
- lircd_uinput_SOURCES    = lircd-uinput.cpp
- lircd_uinput_LDADD     = ../lib/liblirc.la
-diff --git a/plugins/Makefile.am b/plugins/Makefile.am
-index ddff01d..45c012a 100644
---- a/plugins/Makefile.am
-+++ b/plugins/Makefile.am
-@@ -127,6 +127,7 @@ zotac_la_SOURCES            = zotac.c
- plugin_LTLIBRARIES          += mplay.la
- mplay_la_SOURCES            = mplay.c
-+mplay_la_LIBADD             = @LIBCLOCK_GETTIME@
- endif
- $(srcdir)/pluginlist.am:
--- 
-2.7.4
-
diff --git a/package/lirc-tools/0005-lircd-Remove-use-of-functions-killed-in-kernel-4.8.0.patch b/package/lirc-tools/0005-lircd-Remove-use-of-functions-killed-in-kernel-4.8.0.patch
deleted file mode 100644 (file)
index 9fe5256..0000000
+++ /dev/null
@@ -1,105 +0,0 @@
-From 45c590f64dd79e8e1704d5c94ce3456a5cdbfa5f Mon Sep 17 00:00:00 2001
-From: Alec Leamas <leamas.alec@gmail.com>
-Date: Fri, 19 Aug 2016 04:48:02 +0200
-Subject: [PATCH] lircd: Remove use of functions killed in kernel 4.8.0
-
-From 4.8.0 the kernel no longer supports LIRC_NOTIFY_DECODE,
-LIRC_SETUP_START/LIRC_SETUP_END and several constants related
-to initiating filters. Remove corresponding calls from lircd.
-
-[baruch: move DRVCTL_NOTIFY_DECODE into lircd.cpp]
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
----
-Patch status: backported from upstream 31fcc8aa39f62c5c
----
- daemons/lircd.cpp | 53 ++++-------------------------------------------------
- 1 file changed, 4 insertions(+), 49 deletions(-)
-
-diff --git a/daemons/lircd.cpp b/daemons/lircd.cpp
-index 782b6d3f8342..d778aa19308b 100644
---- a/daemons/lircd.cpp
-+++ b/daemons/lircd.cpp
-@@ -78,6 +78,8 @@
- #define lirc_gid gid_t
- #endif
-+#define DRVCTL_NOTIFY_DECODE          7
-+
- #ifdef DARWIN
- #include <mach/mach_time.h>
- #define CLOCK_REALTIME 0
-@@ -462,50 +464,6 @@ static int setup_timeout(void)
- }
--static int setup_filter(void)
--{
--      int ret1, ret2;
--      lirc_t min_pulse_supported = 0, max_pulse_supported = 0;
--      lirc_t min_space_supported = 0, max_space_supported = 0;
--
--      if (!(curr_driver->features & LIRC_CAN_SET_REC_FILTER))
--              return 1;
--      if (curr_driver->drvctl_func(LIRC_GET_MIN_FILTER_PULSE,
--                                   &min_pulse_supported) == -1 ||
--          curr_driver->drvctl_func(LIRC_GET_MAX_FILTER_PULSE, &max_pulse_supported) == -1
--          || curr_driver->drvctl_func(LIRC_GET_MIN_FILTER_SPACE, &min_space_supported) == -1
--          || curr_driver->drvctl_func(LIRC_GET_MAX_FILTER_SPACE, &max_space_supported) == -1) {
--              log_error("could not get filter range");
--              log_perror_err(__func__);
--      }
--
--      if (setup_min_pulse > max_pulse_supported)
--              setup_min_pulse = max_pulse_supported;
--      else if (setup_min_pulse < min_pulse_supported)
--              setup_min_pulse = 0;    /* disable filtering */
--
--      if (setup_min_space > max_space_supported)
--              setup_min_space = max_space_supported;
--      else if (setup_min_space < min_space_supported)
--              setup_min_space = 0;    /* disable filtering */
--
--      ret1 = curr_driver->drvctl_func(LIRC_SET_REC_FILTER_PULSE, &setup_min_pulse);
--      ret2 = curr_driver->drvctl_func(LIRC_SET_REC_FILTER_SPACE, &setup_min_space);
--      if (ret1 == -1 || ret2 == -1) {
--              if (curr_driver->
--                  drvctl_func(LIRC_SET_REC_FILTER,
--                              setup_min_pulse < setup_min_space ? &setup_min_pulse : &setup_min_space) == -1) {
--                      log_error("could not set filter");
--                      log_perror_err(__func__);
--                      return 0;
--              }
--      }
--      return 1;
--}
--
--
--
--
- static int setup_hardware(void)
- {
-       int ret = 1;
-@@ -514,10 +472,7 @@ static int setup_hardware(void)
-               if ((curr_driver->features & LIRC_CAN_SET_REC_CARRIER)
-                   || (curr_driver->features & LIRC_CAN_SET_REC_TIMEOUT)
-                   || (curr_driver->features & LIRC_CAN_SET_REC_FILTER)) {
--                      (void)curr_driver->drvctl_func(LIRC_SETUP_START, NULL);
--                      ret = setup_frequency() && setup_timeout()
--                            && setup_filter();
--                      (void)curr_driver->drvctl_func(LIRC_SETUP_END, NULL);
-+                              ret = setup_frequency() && setup_timeout();
-               }
-       }
-       return ret;
-@@ -2162,7 +2117,7 @@ void loop(void)
-                       int reps;
-                       if (curr_driver->drvctl_func && (curr_driver->features & LIRC_CAN_NOTIFY_DECODE))
--                              curr_driver->drvctl_func(LIRC_NOTIFY_DECODE, NULL);
-+                              curr_driver->drvctl_func(DRVCTL_NOTIFY_DECODE, NULL);
-                       get_release_data(&remote_name, &button_name, &reps);
--- 
-2.9.3
-
index afbca6e19d3643c7906c4647cb0f197020a98feb..239c7664d358312dc9bd3bcd474ac77cd62c9853 100644 (file)
@@ -1,3 +1,3 @@
-# hash from http://sourceforge.net/projects/lirc/files/LIRC/0.9.4/
-sha1 79d2300b4864ed85d6468d554ac777f39b6740ac lirc-0.9.4.tar.bz2
-md5 da6aca942154256bff696d1ffa3ef646 lirc-0.9.4.tar.bz2
+# hash from http://sourceforge.net/projects/lirc/files/LIRC/0.9.4b/
+sha1 7cb2867de1b486708781413aa33568e0612fb912 lirc-0.9.4b.tar.bz2
+md5 9e3f2869a47bbd7c973dd63f30c13fc2 lirc-0.9.4b.tar.bz2
index 547df46e643766cc3f1970dae55a37d7db869af8..bd0f96f337a9da98f2d85dff22f723a1d9a53615 100644 (file)
@@ -4,16 +4,14 @@
 #
 ################################################################################
 
-LIRC_TOOLS_VERSION = 0.9.4
+LIRC_TOOLS_VERSION = 0.9.4b
 LIRC_TOOLS_SOURCE = lirc-$(LIRC_TOOLS_VERSION).tar.bz2
 LIRC_TOOLS_SITE = http://downloads.sourceforge.net/project/lirc/LIRC/$(LIRC_TOOLS_VERSION)
 LIRC_TOOLS_LICENSE = GPLv2+
 LIRC_TOOLS_LICENSE_FILES = COPYING
 LIRC_TOOLS_DEPENDENCIES = host-libxslt host-pkgconf host-python3
 LIRC_TOOLS_INSTALL_STAGING = YES
-# 0001-lib-use-proper-linking-method-to-avoid-parallel-buil.patch
-# 0003-Don-t-build-commandir-unless-we-have-usb.h-191.patch
-# 0004-configure-check-for-clock_gettime-in-librt.patch
+# 0002-configure-check-for-clock_gettime-in-librt.patch
 LIRC_TOOLS_AUTORECONF = YES
 
 LIRC_TOOLS_CONF_ENV = XSLTPROC=yes