package/kismet: add optional support for libcap
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 14:48:42 +0000 (15:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 17:21:21 +0000 (18:21 +0100)
When libcap was compiled before, kismet will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/kismet_server | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libcap.so.2]
[...]

The build system offers no option to en-/disable libcap support:
https://www.kismetwireless.net/gitweb/?p=kismet.git;a=blob;f=configure.ac;h=e874b10f3c1d56e2deb5e8adf4b8da4066fdde56;hb=HEAD#l635

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kismet/kismet.mk

index 64a0ab27699db7c12e334fda7fd36adf088f134c..f4a28b86dca4bb2b2ee3eaf54cf3f0aabe430129 100644 (file)
@@ -15,6 +15,10 @@ KISMET_LICENSE_FILES = debian/copyright
 # We touch configure.in:
 KISMET_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+KISMET_DEPENDENCIES += libcap
+endif
+
 ifeq ($(BR2_PACKAGE_PCRE),y)
 KISMET_DEPENDENCIES += pcre
 endif