htop: bump to version 1.0.3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 28 Apr 2014 12:01:35 +0000 (09:01 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 28 Apr 2014 12:12:29 +0000 (14:12 +0200)
[Peter: also update upstream URL in Config.in]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/htop/Config.in
package/htop/htop-01-native-affinity.patch [new file with mode: 0644]
package/htop/htop.mk
package/htop/htop.patch [deleted file]

index 51304afb53eb749fe716940c2552f5df4497e09b..c19ff27b7745d14e8f7f52884a35b2ceb4041f6e 100644 (file)
@@ -6,4 +6,4 @@ config BR2_PACKAGE_HTOP
          htop is an interactive text-mode process viewer for Linux.
          It aims to be a better top.
 
-         http://htop.sf.net
+         http://hisham.hm/htop/
diff --git a/package/htop/htop-01-native-affinity.patch b/package/htop/htop-01-native-affinity.patch
new file mode 100644 (file)
index 0000000..bf68e53
--- /dev/null
@@ -0,0 +1,25 @@
+# This patch removes the check for native_affinity for cross compiling.
+# This patch has been pushed to htop on 23 November 2011, however, is
+# not in the 1.0 release and may not be exactly what Hisham puts into
+# the official build.
+#
+# Signed-off-by: Andy Kennedy <Andy.Kennedy@adtran.com>
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac     2011-11-20 20:46:48.000000000 -0600
++++ b/configure.ac     2011-11-23 10:41:44.000000000 -0600
+@@ -111,7 +111,6 @@
+ if test "$cross_compiling" = "no"; then
+ AC_CHECK_FILE($PROCDIR/stat,,AC_MSG_ERROR(Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
+ AC_CHECK_FILE($PROCDIR/meminfo,,AC_MSG_ERROR(Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
+-fi
+ AC_ARG_ENABLE(native_affinity, [AC_HELP_STRING([--enable-native-affinity], [enable native sched_setaffinity and sched_getaffinity for affinity support, disables hwloc])], ,enable_native_affinity="yes")
+ if test "x$enable_native_affinity" = xyes; then
+@@ -130,6 +129,7 @@
+       AC_MSG_RESULT([yes])],
+      [AC_MSG_RESULT([no])])
+ fi
++fi
+ AC_ARG_ENABLE(hwloc, [AC_HELP_STRING([--enable-hwloc], [enable hwloc support for CPU affinity])],, enable_hwloc="no")
+ if test "x$enable_hwloc" = xyes
index fe9b302c927e4aed2bdb51266dbfb3b30832946a..a1ec56fbb7c5cd3edf9de6adac00353a041f4598 100644 (file)
@@ -4,9 +4,10 @@
 #
 ################################################################################
 
-HTOP_VERSION = 1.0.2
-HTOP_SITE = http://downloads.sourceforge.net/project/htop/htop/$(HTOP_VERSION)
+HTOP_VERSION = 1.0.3
+HTOP_SITE = http://hisham.hm/htop/releases/$(HTOP_VERSION)
 HTOP_DEPENDENCIES = ncurses
+# For htop-01-native-affinity.patch
 HTOP_AUTORECONF = YES
 HTOP_CONF_OPT = --disable-unicode
 HTOP_CONF_ENV = ac_cv_file__proc_stat=yes ac_cv_file__proc_meminfo=yes
diff --git a/package/htop/htop.patch b/package/htop/htop.patch
deleted file mode 100644 (file)
index bf68e53..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# This patch removes the check for native_affinity for cross compiling.
-# This patch has been pushed to htop on 23 November 2011, however, is
-# not in the 1.0 release and may not be exactly what Hisham puts into
-# the official build.
-#
-# Signed-off-by: Andy Kennedy <Andy.Kennedy@adtran.com>
-diff -Naur a/configure.ac b/configure.ac
---- a/configure.ac     2011-11-20 20:46:48.000000000 -0600
-+++ b/configure.ac     2011-11-23 10:41:44.000000000 -0600
-@@ -111,7 +111,6 @@
- if test "$cross_compiling" = "no"; then
- AC_CHECK_FILE($PROCDIR/stat,,AC_MSG_ERROR(Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
- AC_CHECK_FILE($PROCDIR/meminfo,,AC_MSG_ERROR(Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
--fi
- AC_ARG_ENABLE(native_affinity, [AC_HELP_STRING([--enable-native-affinity], [enable native sched_setaffinity and sched_getaffinity for affinity support, disables hwloc])], ,enable_native_affinity="yes")
- if test "x$enable_native_affinity" = xyes; then
-@@ -130,6 +129,7 @@
-       AC_MSG_RESULT([yes])],
-      [AC_MSG_RESULT([no])])
- fi
-+fi
- AC_ARG_ENABLE(hwloc, [AC_HELP_STRING([--enable-hwloc], [enable hwloc support for CPU affinity])],, enable_hwloc="no")
- if test "x$enable_hwloc" = xyes