package/aespipe: bump version to 2.4f
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 26 Oct 2019 08:21:20 +0000 (10:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Oct 2019 13:18:59 +0000 (15:18 +0200)
Updated link to package homepage since old link is just a redirect now.

Added sha1 and md5 hashes provided by upstream.

Removed -no-pie workaround after upstream added a check in configure,
quoting ChangeLog:

- Added configure script autodetection for x86/amd64 -fno-pie compile
  and -no-pie linker flags. These are needed when compiler/linker
  produces position independent executable (PIE) by default.

Build-tested host-aespipe on Debian Buster 10.1 using
"gcc version 8.3.0 (Debian 8.3.0-6)"

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/aespipe/Config.in
package/aespipe/Config.in.host
package/aespipe/aespipe.hash
package/aespipe/aespipe.mk

index 2c2ff5cd8c553670db05645fe05f4f0d2d602836..e1683a0aa2de1751c3d0300f99da341ba563fabf 100644 (file)
@@ -8,4 +8,4 @@ config BR2_PACKAGE_AESPIPE
          It can be used to encrypt and decrypt loop-AES compatible
          encrypted disk images.
 
-         http://koti.tnnet.fi/jari.ruusu/linux/
+         http://loop-aes.sourceforge.net/
index b64868ce74bc5003f9cc98abfcf11b73106ac2cd..1e98c21c9af2fc60b2be17c5f9b6de7158c351a7 100644 (file)
@@ -7,4 +7,4 @@ config BR2_PACKAGE_HOST_AESPIPE
          archives. It can be used to encrypt and decrypt loop-AES
          compatible encrypted disk images.
 
-         http://koti.tnnet.fi/jari.ruusu/linux/
+         http://loop-aes.sourceforge.net/
index 7e3a16503c79d221bcdf39b086841007db52275c..134a16df486d2f1782d71ca5b92f366eeb1768c4 100644 (file)
@@ -1,2 +1,5 @@
+# From https://sourceforge.net/projects/loop-aes/files/aespipe/v2.4f/
+sha1 2c23e1a6be298cf4f173f06b1123e4ecd5e9a202  aespipe-v2.4f.tar.bz2
+md5 ed05c62c1954110f009bedda4bc1562f  aespipe-v2.4f.tar.bz2
 # Locally computed:
-sha256 bad5abb8678c2a6062d22b893171623e0c8e6163b5c1e6e5086e2140e606b93a  aespipe-v2.4e.tar.bz2
+sha256 b135e1659f58dc9be5e3c88923cd03d2a936096ab8cd7f2b3af4cb7a844cef96  aespipe-v2.4f.tar.bz2
index aa25420f110e848febe41cddb5ca7502bbf5510e..fd4f776dda942414f947c02ad6b2e9168c94f0b9 100644 (file)
@@ -4,20 +4,10 @@
 #
 ################################################################################
 
-AESPIPE_VERSION = 2.4e
+AESPIPE_VERSION = 2.4f
 AESPIPE_SOURCE = aespipe-v$(AESPIPE_VERSION).tar.bz2
 AESPIPE_SITE = http://loop-aes.sourceforge.net/aespipe
 AESPIPE_LICENSE = GPL
 
-# Recent Debian, Gentoo and Ubuntu enable -fPIE by default, breaking the build:
-# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837393
-# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835148
-# Older gcc versions however don't support the -no-pie flag, so we have to
-# check its availability.
-HOST_AESPIPE_NO_PIE_FLAG = $(call host-cc-option,-no-pie)
-HOST_AESPIPE_CONF_ENV = \
-       CFLAGS="$(HOST_CFLAGS) $(HOST_AESPIPE_NO_PIE_FLAG)" \
-       LDFLAGS="$(HOST_LDFLAGS) $(HOST_AESPIPE_NO_PIE_FLAG)"
-
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))