manual generation: rename manual-txt into manual-text
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Fri, 18 Oct 2013 20:31:26 +0000 (22:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Nov 2013 15:57:34 +0000 (16:57 +0100)
The output extension and the generation messages refer to 'text', but the make
target was confusingly 'txt'. This patch changes the make target for
consistency.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
docs/manual/manual.mk

index f266e2dd77bf89bdfa91801558606e91cd8455e7..1496bd74fca0da8b5a5f455b9e1bc100d0eb8385 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -797,7 +797,7 @@ endif
        @echo '  manual-html            - build manual in HTML'
        @echo '  manual-split-html      - build manual in split HTML'
        @echo '  manual-pdf             - build manual in PDF'
-       @echo '  manual-txt             - build manual in txt'
+       @echo '  manual-text            - build manual in text'
        @echo '  manual-epub            - build manual in ePub'
        @echo
        @echo 'Miscellaneous:'
@@ -821,7 +821,7 @@ release: OUT=buildroot-$(BR2_VERSION)
 # documentation to the git output
 release:
        git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
-       $(MAKE) O=$(OUT) manual-html manual-txt manual-pdf
+       $(MAKE) O=$(OUT) manual-html manual-text manual-pdf
        tar rf $(OUT).tar $(OUT)
        gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
        bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
index fcfe47be70ba758111dff17692aac1be0314a401..aeafd10d7ae3f82b432543b3615ffe6a57fef974 100644 (file)
@@ -75,7 +75,7 @@ define GENDOC
 $(call GENDOC_INNER,$(1),xhtml,html,html,HTML,--xsltproc-opts "--stringparam toc.section.depth 4")
 $(call GENDOC_INNER,$(1),chunked,split-html,chunked,split HTML,--xsltproc-opts "--stringparam toc.section.depth 4")
 $(call GENDOC_INNER,$(1),pdf,pdf,pdf,PDF,--dblatex-opts "-P latex.output.revhistory=0")
-$(call GENDOC_INNER,$(1),text,txt,text,text)
+$(call GENDOC_INNER,$(1),text,text,text,text)
 $(call GENDOC_INNER,$(1),epub,epub,epub,ePUB)
 clean: $(1)-clean
 $(1)-clean: