package/seatd: disable -Werror
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 12 Jun 2021 21:15:02 +0000 (23:15 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 13 Jul 2021 19:47:19 +0000 (21:47 +0200)
Disable -Werror to avoid the following build failure which is raised
since the addition of the package in commit
daae31149017cbf8b03634cfc56da132f7e1ad83

../seatd/seat.c: In function 'seat_activate_device':
../seatd/seat.c:374:48: error: unused parameter 'client' [-Werror=unused-parameter]
  374 | static int seat_activate_device(struct client *client, struct seat_device *seat_device) {
      |                                 ~~~~~~~~~~~~~~~^~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/0ec925aab23d83c52684f5fea7a4395c93a674c4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Tested-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/seatd/seatd.mk

index 2abcefbfaa757c4d67cfd4d460eee88d5eaea008..bf582f0d1d9c63208fd6f838160f1bcf5a14f6cc 100644 (file)
@@ -13,7 +13,8 @@ SEATD_INSTALL_STAGING = YES
 
 SEATD_CONF_OPTS += \
        -Dman-pages=disabled \
-       -Dexamples=disabled
+       -Dexamples=disabled \
+       -Dwerror=false
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_LOGIND),y)
 SEATD_CONF_OPTS += -Dlogind=enabled