odhcp6c: new package
authorAlexander Clouter <alex+buildroot@digriz.org.uk>
Mon, 2 Feb 2015 15:39:27 +0000 (16:39 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Feb 2015 21:49:55 +0000 (22:49 +0100)
Signed-off-by: Alexander Clouter <alex+buildroot@digriz.org.uk>
[ThomasDS: needs ipv6; rewrap package/odhcp6c/Config.in]
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Tested-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
(compile-tested on x86/glibc, armel/glibc, armel/uclibc)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/odhcp6c/Config.in [new file with mode: 0644]
package/odhcp6c/odhcp6c.mk [new file with mode: 0644]

index bcd1481b0654a1607a3b0ae62594dcdfab03dbab..0f5836bd0e68f7ef08bddb3f87fcc2bcb80e1f12 100644 (file)
@@ -1135,6 +1135,7 @@ endif
        source "package/noip/Config.in"
        source "package/ntp/Config.in"
        source "package/nuttcp/Config.in"
+       source "package/odhcp6c/Config.in"
        source "package/odhcploc/Config.in"
        source "package/olsr/Config.in"
        source "package/openntpd/Config.in"
diff --git a/package/odhcp6c/Config.in b/package/odhcp6c/Config.in
new file mode 100644 (file)
index 0000000..92de0e5
--- /dev/null
@@ -0,0 +1,11 @@
+comment "odhcp6c needs a toolchain w/ IPv6"
+       depends on !BR2_INET_IPV6
+
+config BR2_PACKAGE_ODHCP6C
+       bool "odhcp6c"
+       depends on BR2_INET_IPV6
+       help
+         odhcp6c is a minimal DHCPv6 and RA-client for use in embedded Linux
+         systems, especially routers.
+
+         https://github.com/sbyx/odhcp6c
diff --git a/package/odhcp6c/odhcp6c.mk b/package/odhcp6c/odhcp6c.mk
new file mode 100644 (file)
index 0000000..db963e0
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# odhcp6c
+#
+################################################################################
+
+ODHCP6C_VERSION = c42e34111e19bd435dc4b5bb3ba81224ea214314
+ODHCP6C_SITE = $(call github,sbyx,odhcp6c,$(ODHCP6C_VERSION))
+ODHCP6C_LICENSE = GPLv2
+ODHCP6C_LICENSE_FILES = COPYING
+
+$(eval $(cmake-package))