iw: simplify static linking handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 7 Mar 2015 11:40:22 +0000 (12:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Mar 2015 17:09:25 +0000 (18:09 +0100)
Now that libnl pkg-config file is correct, there is no need to have
special handling for static linking in the iw package: it already uses
pkg-config to get the necessary flags to link with libnl.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iw/iw.mk

index df6e25711a3e0fe92fe2b7818eb04e936ebaf122..1286915a6b992f7186c60f03bf2127948dea17ff 100644 (file)
@@ -14,12 +14,6 @@ IW_MAKE_OPTS = CC="$(TARGET_CC)" LD="$(TARGET_LD)" LDFLAGS="$(TARGET_LDFLAGS)"
 IW_MAKE_ENV = PKG_CONFIG="$(HOST_DIR)/usr/bin/pkg-config" \
        GIT_DIR=$(IW_DIR)
 
-ifeq ($(BR2_STATIC_LIBS),y)
-# libnl needs pthread/m, so we need to explicitly with them when static
-# these need to added AFTER libnl, so we have to override LIBS completely
-IW_MAKE_OPTS += LIBS='-lnl-genl-3 -lnl-3 -lpthread -lm'
-endif
-
 define IW_BUILD_CMDS
        $(IW_MAKE_ENV) $(MAKE) $(IW_MAKE_OPTS) -C $(@D)
 endef