package: add libconfig package
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 1 Sep 2008 10:51:31 +0000 (10:51 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 1 Sep 2008 10:51:31 +0000 (10:51 -0000)
package/Config.in
package/libconfig/Config.in [new file with mode: 0644]
package/libconfig/libconfig.mk [new file with mode: 0644]

index cccd455a243dbce7600a0484956fa460c40bad1c..3f4b45476090187b9cb7f8654b34160bd25986f6 100644 (file)
@@ -77,6 +77,7 @@ source "package/kexec/Config.in"
 if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
 source "package/less/Config.in"
 endif
+source "package/libconfig/Config.in"
 source "package/libdaemon/Config.in"
 source "package/libelf/Config.in"
 source "package/libevent/Config.in"
diff --git a/package/libconfig/Config.in b/package/libconfig/Config.in
new file mode 100644 (file)
index 0000000..75dacab
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBCONFIG
+       bool "libconfig"
+       help
+         Libconfig is a simple library for manipulating structured
+         configuration files. The file format is more compact and more
+         readable than XML. And unlike XML, it is type-aware, so it is
+         not necessary to do string parsing in application code.
+
+         http://www.hyperrealm.com/libconfig/
diff --git a/package/libconfig/libconfig.mk b/package/libconfig/libconfig.mk
new file mode 100644 (file)
index 0000000..8e7ef0b
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# libconfig
+#
+#############################################################
+LIBCONFIG_VERSION:=1.3
+LIBCONFIG_SOURCE:=libconfig-$(LIBCONFIG_VERSION).tar.gz
+LIBCONFIG_SITE:=http://www.hyperrealm.com/libconfig/
+LIBCONFIG_AUTORECONF:=NO
+LIBCONFIG_INSTALL_STAGING:=YES
+LIBCONFIG_INSTALL_TARGET:=YES
+LIBCONFIG_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
+
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
+LIBCONFIG_CONF_OPT:=--disable-cxx
+endif
+
+LIBCONFIG_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,libconfig))