qt5base: add an option to build and install examples
authorFatih Aşıcı <fatih.asici@gmail.com>
Thu, 2 Jan 2014 07:07:02 +0000 (09:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 2 Jan 2014 14:04:16 +0000 (15:04 +0100)
Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com>
Tested-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index e932e240a48859b6c5e711f09f693ecee425fbaf..3090d65a27b892ae5a2acf138a008a414cd82d7b 100644 (file)
@@ -28,6 +28,13 @@ config BR2_PACKAGE_QT5BASE_LICENSE_APPROVED
 
          See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
 
+config BR2_PACKAGE_QT5BASE_EXAMPLES
+       bool "Compile and install examples (with code)"
+       select BR2_PACKAGE_QT5BASE_NETWORK
+       select BR2_PACKAGE_QT5BASE_XML
+       help
+         If unsure, say N.
+
 config BR2_PACKAGE_QT5BASE_NETWORK
        bool "network module"
        help
index e46bdebe550f60cd1d14fdd8309d4429970009ac..6928bb81cec9c30fb2b09744a9d81551d81cfea5 100644 (file)
@@ -134,6 +134,8 @@ QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_LIBGLIB2),libglib2)
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_ICU),-icu,-no-icu)
 QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_ICU),icu)
 
+QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_EXAMPLES),-make,-nomake) examples
+
 # Build the list of libraries to be installed on the target
 QT5BASE_INSTALL_LIBS_y                                 += Qt5Core
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_NETWORK)    += Qt5Network
@@ -162,8 +164,9 @@ define QT5BASE_CONFIGURE_CMDS
                -headerdir /usr/include/qt5 \
                -sysroot $(STAGING_DIR) \
                -plugindir /usr/lib/qt/plugins \
+               -examplesdir /usr/lib/qt/examples \
                -no-rpath \
-               -nomake examples -nomake tests \
+               -nomake tests \
                -device buildroot \
                -device-option CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
                -device-option BUILDROOT_COMPILER_CFLAGS="$(TARGET_CFLAGS)" \
@@ -203,15 +206,24 @@ define QT5BASE_INSTALL_TARGET_FONTS
        fi
 endef
 
+define QT5BASE_INSTALL_TARGET_EXAMPLES
+       if [ -d $(STAGING_DIR)/usr/lib/qt/examples/ ] ; then \
+               mkdir -p $(TARGET_DIR)/usr/lib/qt/examples ; \
+               cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/* $(TARGET_DIR)/usr/lib/qt/examples ; \
+       fi
+endef
+
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 define QT5BASE_INSTALL_TARGET_CMDS
        $(QT5BASE_INSTALL_TARGET_FONTS)
+       $(QT5BASE_INSTALL_TARGET_EXAMPLES)
 endef
 else
 define QT5BASE_INSTALL_TARGET_CMDS
        $(QT5BASE_INSTALL_TARGET_LIBS)
        $(QT5BASE_INSTALL_TARGET_PLUGINS)
        $(QT5BASE_INSTALL_TARGET_FONTS)
+       $(QT5BASE_INSTALL_TARGET_EXAMPLES)
 endef
 endif