cloop: bump and fix package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 16 Dec 2010 09:47:34 +0000 (10:47 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 28 Dec 2010 19:13:05 +0000 (20:13 +0100)
On a machine without zlib-dev installed, cloop must rely on the
host-zlib compiled by Buildroot, but due to the horrible cloop build
system, this didn't happen and the build was failing.

Therefore, we now pass all the $(HOST_CONFIGURE_OPTS) when building
cloop, and we fix the Makefile so that it takes into account
CFLAGS/LDFLAGS passed in the environment or command-line and do not
override them.

[Peter: fix typos, remove HOST_MAKE_ENV]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cloop/cloop-2.634-1-cflags.patch [new file with mode: 0644]
package/cloop/cloop.mk

diff --git a/package/cloop/cloop-2.634-1-cflags.patch b/package/cloop/cloop-2.634-1-cflags.patch
new file mode 100644 (file)
index 0000000..c421dd7
--- /dev/null
@@ -0,0 +1,30 @@
+Take into account the CFLAGS/LDFLAGS passed in the environment.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: host-cloop-2.634-1/Makefile
+===================================================================
+--- host-cloop-2.634-1.orig/Makefile   2010-12-16 09:17:52.826555645 +0100
++++ host-cloop-2.634-1/Makefile        2010-12-16 09:18:57.208713338 +0100
+@@ -15,7 +15,7 @@
+ endif
+ ifdef APPSONLY
+-CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer 
++CLOOP_CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer 
+ endif
+ KERNOBJ:=compressed_loop.o
+@@ -53,10 +53,10 @@
+       ( cd advancecomp-1.15 ; ./configure && $(MAKE) advfs )
+ extract_compressed_fs: extract_compressed_fs.c
+-      $(CC) -Wall -O2 -s -o $@ $< -lz
++      $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -Wall -O2 -s -o $@ $< -lz
+ cloop_suspend: cloop_suspend.o
+-      $(CC) -o $@ $<
++      $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -o $@ $<
+ clean:
+       rm -rf create_compressed_fs extract_compressed_fs zoom *.o *.ko Module.symvers .cloop* .compressed_loop.* .tmp*
index 4c160986c9ce29d2cd86a54cea99776076a4f0c8..fa47a5f5f51f25162ec773fa26dd68c8643a9254 100644 (file)
@@ -1,12 +1,11 @@
-CLOOP_VERSION=2.631-1
+CLOOP_VERSION=2.634-1
 CLOOP_SOURCE=cloop_$(CLOOP_VERSION).tar.gz
 CLOOP_SITE=http://debian-knoppix.alioth.debian.org/packages/sources/cloop
 
 HOST_CLOOP_DEPENDENCIES = host-zlib
 
 define HOST_CLOOP_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE1) \
-   CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_ERROR_SILENT" -C $(@D) APPSONLY=yes
+       $(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D) APPSONLY=yes
 endef
 
 define HOST_CLOOP_INSTALL_CMDS