micropython: Set MICROPY_GCREGS_SETJMP=1 for xtensa and sh
authorChris Packham <judge.packham@gmail.com>
Fri, 18 Sep 2015 09:19:35 +0000 (21:19 +1200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Sep 2015 12:00:15 +0000 (14:00 +0200)
These architectures don't have explicit exception handling support in
micropython but can use the setjmp fallback behaviour instead.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/micropython/micropython.mk

index 2d7c9240703882582348f2a6d1b8acb9bf28d3f3..62668828af86fbb35d6584e905af9e4555264be0 100644 (file)
@@ -12,7 +12,7 @@ MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
 
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.
-ifeq ($(BR2_powerpc),y)
+ifeq ($(BR2_powerpc)$(BR2_sh)$(BR2_xtensa),y)
 MICROPYTHON_CFLAGS = -DMICROPY_GCREGS_SETJMP=1
 endif