gst-plugins-good: Add option for v4l2
authorPhil Edworthy <phil.edworthy@renesas.com>
Tue, 16 Nov 2010 13:28:09 +0000 (13:28 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 Dec 2010 23:17:19 +0000 (00:17 +0100)
Signed-off-by: Phil Edworthy <phil.edworthy@renesas.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-good/Config.in
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index 3b37b5e78e64aeb56c9268a48134d5bdd74be1da..dd293e9c17e6bb4cce0b1743552f94c584a6d88f 100644 (file)
@@ -159,6 +159,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPARSE
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_Y4M
        bool "y4m"
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_V4L2
+       bool "v4l2"
+
 comment "plugins with external dependencies"
 
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX
index c44bdff5079b6ef8a148a59e44c0afa5835514cf..62d9d47016666d6fcb5ac60a8a7c908ae03c5229 100644 (file)
@@ -15,7 +15,6 @@ GST_PLUGINS_GOOD_CONF_OPT = \
                --disable-sunaudio \
                --disable-osx_audio \
                --disable-osx_video \
-               --disable-gst_v4l2 \
                --disable-x \
                --disable-xshm \
                --disable-xvideo \
@@ -290,6 +289,12 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-y4m
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_V4L2),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-gst_v4l2
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-gst_v4l2
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-annodex
 GST_PLUGINS_GOOD_DEPENDENCIES += libxml2