package/boost: add library coroutine2
authorJörg Krause <joerg.krause@embedded.rocks>
Fri, 11 Dec 2015 13:57:59 +0000 (14:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Dec 2015 12:53:48 +0000 (13:53 +0100)
Coroutine2 is a new (C++14) library added in boost 1.59.0. We also add
coroutine2 to the '--without-libraries' configuration flag for the host
variant.

Build successfully tested with Arago ARMv5 2011.09 - a gcc v4.5.3 toolchain.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index 97d080243a74c2a8bf21ca5c9450d8827a57b37d..83f6871e89287e0ecd457bddf7eefd76552fd0c0 100644 (file)
@@ -78,6 +78,10 @@ config BR2_PACKAGE_BOOST_COROUTINE
        bool "boost-coroutine"
        depends on BR2_PACKAGE_BOOST_CONTEXT
 
+config BR2_PACKAGE_BOOST_COROUTINE2
+       bool "boost-coroutine2"
+       depends on BR2_PACKAGE_BOOST_CONTEXT
+
 config BR2_PACKAGE_BOOST_DATE_TIME
        bool "boost-date_time"
 
index 2f23fe1b9bde13184171f28137a731899a976a44..0161d68678f234871d9078056d6be774590e0773 100644 (file)
@@ -16,15 +16,16 @@ HOST_BOOST_DEPENDENCIES =
 # keep host variant as minimal as possible
 HOST_BOOST_FLAGS = --without-icu \
        --without-libraries=$(subst $(space),$(comma),atomic chrono context \
-       coroutine date_time exception filesystem graph graph_parallel \
-       iostreams locale log math mpi program_options python random regex \
-       serialization signals system test thread timer wave)
+       coroutine coroutine2 date_time exception filesystem graph \
+       graph_parallel iostreams locale log math mpi program_options python \
+       random regex serialization signals system test thread timer wave)
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTAINER),,container)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_COROUTINE),,coroutine)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_COROUTINE2),,coroutine2)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_EXCEPTION),,exception)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,filesystem)