package/libevent: add support for libressl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 2 Apr 2018 11:58:27 +0000 (13:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 16:29:46 +0000 (18:29 +0200)
Libevent builds fine with current libressl 2.7.2.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libevent/libevent.mk

index 65bf1c2b7b9f91e07e266988f6cb23bcff6ff819..f0c989afa1200c5a6b9a9648065583030d263752 100644 (file)
@@ -24,8 +24,8 @@ ifneq ($(BR2_PACKAGE_PYTHON),y)
 LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
 endif
 
-ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
-LIBEVENT_DEPENDENCIES += host-pkgconf libopenssl
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBEVENT_DEPENDENCIES += host-pkgconf openssl
 LIBEVENT_CONF_OPTS += --enable-openssl
 else
 LIBEVENT_CONF_OPTS += --disable-openssl