package/vim: add optional support for acl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 22:45:41 +0000 (23:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 11:29:08 +0000 (12:29 +0100)
When acl was compiled before, vim will use it as optional dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/vim | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libacl.so.1]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vim/vim.mk

index 07493669d67829fa781eb930230b881f17bd02e7..6e05050f1e2fb7bc6c107a171097f3f6d6815d79 100644 (file)
@@ -27,6 +27,13 @@ VIM_CONF_OPTS = --with-tlib=ncurses --enable-gui=no --without-x
 VIM_LICENSE = Charityware
 VIM_LICENSE_FILES = README.txt
 
+ifeq ($(BR2_PACKAGE_ACL),y)
+VIM_CONF_OPTS += --enable-acl
+VIM_DEPENDENCIES += acl
+else
+VIM_CONF_OPTS += --disable-acl
+endif
+
 ifeq ($(BR2_PACKAGE_GPM),y)
 VIM_CONF_OPTS += --enable-gpm
 VIM_DEPENDENCIES += gpm