Jan Lana writes:
authorEric Andersen <andersen@codepoet.org>
Wed, 27 Oct 2004 20:09:27 +0000 (20:09 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 27 Oct 2004 20:09:27 +0000 (20:09 -0000)
Hi,

package/ncurses/ncurses.mk doesn't create root/usr/include directory before installation.
There is a simple patch.

- Jenda

package/ncurses/ncurses.mk

index f3fb02a7cee40c1e8460f907524eb10fa51c84f2..09ce6f0be0f2849663fdf28bf6fc8e56b39cd0ae 100644 (file)
@@ -5,7 +5,7 @@
 #
 #############################################################
 # Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.5 2004/10/09 21:19:18 andersen Exp $
+# $Id: ncurses.mk,v 1.6 2004/10/27 20:09:27 andersen Exp $
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU Library General Public License as
@@ -103,6 +103,7 @@ $(TARGET_DIR)/lib/libncurses.so.5.2: $(STAGING_DIR)/lib/libncurses.a
        touch -c $(TARGET_DIR)/lib/libncurses.so.5.2
 
 $(TARGET_DIR)/usr/lib/libncurses.a: $(STAGING_DIR)/lib/libncurses.a
+       mkdir -p $(TARGET_DIR)/usr/include
        cp -dpf $(NCURSES_DIR)/include/curses.h $(TARGET_DIR)/usr/include/ncurses.h
        cp -dpf $(NCURSES_DIR)/include/term.h $(TARGET_DIR)/usr/include/
        cp -dpf $(NCURSES_DIR)/include/unctrl.h $(TARGET_DIR)/usr/include/