toolchain-external: update Arm AArch64 toolchain 8.2-2018.11
authorRomain Naour <romain.naour@gmail.com>
Wed, 2 Jan 2019 22:14:07 +0000 (23:14 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Jan 2019 11:45:17 +0000 (12:45 +0100)
>From [1]:
* All GCC 8.2 features. For details on GCC 8 release series.
* Linaro specific pre-processor macros to ensure that this is a
  continuation from the Linaro releases.
* Spectre v1 mitigation backport from upstream FSF trunk include the
  revisions. This is an initial backport of those mitigations in
  the GNU toolchain and should be regarded as support for prototyping
  and early access only. Moreover, while the backports include support
  for the other architectures, they are included for completeness and
  all issues regarding these patches must be taken up upstream in the
  https://gcc.gnu.org/bugzilla by reproducing the same with upstream
  FSF trunk.
  Arm is interested in feedback regarding these workarounds for
  Spectre v1.
  A description of the mitigation has been published on LWN.net.

See "Release Note":
[1] https://developer.arm.com/open-source/gnu-toolchain/gnu-a/downloads#

Tested with qemu_aarch64_virt_defconfig.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/toolchain-external/toolchain-external-arm-aarch64/Config.in
toolchain/toolchain-external/toolchain-external-arm-aarch64/toolchain-external-arm-aarch64.hash
toolchain/toolchain-external/toolchain-external-arm-aarch64/toolchain-external-arm-aarch64.mk

index ba627129cbe4cb66726239c073aea3c7b7265d40..fbb5e025e858548ce57ded8e93cc1aa497947c18 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_TOOLCHAIN_EXTERNAL_ARM_AARCH64
-       bool "Arm AArch64 2018.08"
+       bool "Arm AArch64 2018.11"
        depends on BR2_aarch64
        depends on BR2_HOSTARCH = "x86_64"
        depends on !BR2_STATIC_LIBS
@@ -7,7 +7,7 @@ config BR2_TOOLCHAIN_EXTERNAL_ARM_AARCH64
        select BR2_TOOLCHAIN_HAS_SSP
        select BR2_INSTALL_LIBSTDCPP
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_18
+       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_20
        select BR2_TOOLCHAIN_GCC_AT_LEAST_8
        select BR2_TOOLCHAIN_HAS_FORTRAN
        help
index d651bb0182f5f4c65271673505ff561793e58aee..cda90f7517ad40375ceed5a4201da0754a7dda3b 100644 (file)
@@ -1,4 +1,4 @@
-# From https://developer.arm.com/-/media/Files/downloads/gnu-a/8.2-2018.08/gcc-arm-8.2-2018.08-x86_64-aarch64-linux-gnu.tar.xz.asc
-md5 1c47f4edc431cf19604a9f1b09975269 gcc-arm-8.2-2018.08-x86_64-aarch64-linux-gnu.tar.xz
+# From https://developer.arm.com/-/media/Files/downloads/gnu-a/8.2-2018.11/gcc-arm-8.2-2018.11-x86_64-aarch64-linux-gnu.tar.xz.asc
+md5 319ca548ff05b0ec1008988a7e5ab619 gcc-arm-8.2-2018.11-x86_64-aarch64-linux-gnu.tar.xz
 # locally calculated
-sha256 3e60644846ac60693e58ad71a319d64c5f7bcf95ff34411272c8d9674f85648f gcc-arm-8.2-2018.08-x86_64-aarch64-linux-gnu.tar.xz
+sha256 0142366da2f30feb1c366997cbdaa02286c8f1aa527c0fc177ee5ce8e77970fc gcc-arm-8.2-2018.11-x86_64-aarch64-linux-gnu.tar.xz
index 515b66cd79eb84535ce5fee49aa675453d609e6c..0398bd1297800b8081e3fe3220df32eebde1f7c5 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TOOLCHAIN_EXTERNAL_ARM_AARCH64_VERSION = 2018.08
+TOOLCHAIN_EXTERNAL_ARM_AARCH64_VERSION = 2018.11
 TOOLCHAIN_EXTERNAL_ARM_AARCH64_SITE = https://developer.arm.com/-/media/Files/downloads/gnu-a/8.2-$(TOOLCHAIN_EXTERNAL_ARM_AARCH64_VERSION)
 
 TOOLCHAIN_EXTERNAL_ARM_AARCH64_SOURCE = gcc-arm-8.2-$(TOOLCHAIN_EXTERNAL_ARM_AARCH64_VERSION)-x86_64-aarch64-linux-gnu.tar.xz