package/libshout: enable optional dependency for libressl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 23 Sep 2017 09:19:49 +0000 (11:19 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 26 Sep 2017 21:50:14 +0000 (23:50 +0200)
libshout uses pkgconfig currently only to check for openssl paths, to
fix the build error we pass our STAGING_DIR as parameter to
--with-openssl

Fixes
http://autobuild.buildroot.net/results/72a/72aa07d48d6b1d7dea046b88ee4aa943534ffad4/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libshout/libshout.mk

index 8fd850fb132ddc4e7c27cb7f83bf2546cfffbaf1..4f209081a42f7fb7baeed766f24cc5ab7f74c524 100644 (file)
@@ -31,6 +31,9 @@ endif
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBSHOUT_CONF_OPTS += --with-openssl
 LIBSHOUT_DEPENDENCIES += openssl
+else ifeq ($(BR2_PACKAGE_LIBRESSL),y)
+LIBSHOUT_CONF_OPTS += --with-openssl=$(STAGING_DIR)/lib
+LIBSHOUT_DEPENDENCIES += libressl
 else
 LIBSHOUT_CONF_OPTS += --without-openssl
 endif