linux-advanced: don't error out on non writable /tftpboot
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Feb 2009 10:38:10 +0000 (10:38 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Feb 2009 10:38:10 +0000 (10:38 -0000)
Odd that we have 2x the same target right after eachother, but this is
Makefile.in.advanced ofcourse ;)

target/linux/Makefile.in.advanced

index 240a251e3e6b2ce5fce185edd7f8b3d0a2bbe3b2..565a4c9e7dbb71393610c04b233e94d343cec8e0 100644 (file)
@@ -459,7 +459,7 @@ $(TARGET_DIR)/boot/busybox.config: $(BUSYBOX_DIR)/.config
 /tftpboot/$(LINUX26_KERNEL_NAME): $(LINUX26_KERNEL)
        -mkdir -p /tftpboot
        -cp -dpf $(LINUX26_KERNEL) $@
-       touch $@
+       -touch $@
 
 ifneq ($(LINUX_COPYTO),/tftpboot)
 $(LINUX_COPYTO)/$(LINUX26_KERNEL_NAME): $(LINUX26_KERNEL)