projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
458ce81
)
Ensure we use host 'make', even when building 'make' in buildroot
author
Ulf Samuelsson
<ulf.samuelsson@atmel.com>
Tue, 17 Jul 2007 12:09:07 +0000
(12:09 -0000)
committer
Ulf Samuelsson
<ulf.samuelsson@atmel.com>
Tue, 17 Jul 2007 12:09:07 +0000
(12:09 -0000)
package/Makefile.in
patch
|
blob
|
history
diff --git
a/package/Makefile.in
b/package/Makefile.in
index 2fe65835353dbf49864a86c435a9017aa3aca20a..29c505835fa8341b86c84bc757aa265feb940f04 100644
(file)
--- a/
package/Makefile.in
+++ b/
package/Makefile.in
@@
-1,8
+1,13
@@
-ifndef MAKE
-MAKE=make
+ifndef MAKE
+MAKE
:
=make
endif
-MAKE1:=$(MAKE) MAKE="$(firstword $(MAKE)) -j1"
-MAKE:=$(MAKE) -j$(BR2_JLEVEL)
+ifndef HOSTMAKE
+HOSTMAKE=$(MAKE)
+endif
+HOSTMAKE :=$(shell $(CONFIG_SHELL) -c "which $(HOSTMAKE)" || type -p $(HOSTMAKE) || echo make)
+
+MAKE1:=$(HOSTMAKE) MAKE="$(firstword $(HOSTMAKE)) -j1"
+MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))